POJ2318 TOYS 解题报告【二分答案+向量叉积】

Description
Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are “in” the box.
解题报告
这道题的题意是,有一个箱子,其中有n个隔板,m个玩具,询问每一个玩具在哪一个区域里。
我们一看,这个题用二分答案来判断点的位置,至于check,我们知道判定一个点在线段那一边的方法叫做向量叉积。
代码如下:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define Point Vector
const int N=5000;
struct Vector
{
    int x,y;
    Vector(double a=.0,double b=.0):x(a),y(b){}
    Vector operator+(const Vector &s){return Vector(x+s.x,y+s.y);}
    Vector operator-(const Vector &s){return Vector(x-s.x,y-s.y);}
    Vector operator*(double s){return Vector(x*s,y*s);}
    Vector operator/(double s){return Vector(x/s,y/s);}
};
struct Node
{
    Point a,b;
}A[N+5];
int cross(const Vector &a,const Vector &b){return a.x*b.y-a.y*b.x;}//向量叉积 
bool check(Point p,int mid)
{
    return cross(A[mid].a-p,A[mid].b-p)>0;
}
int n,m;
int pos[N+5];
int main()
{
    while(scanf("%d",&n)&&n)
    {
        memset(pos,0,sizeof(pos));
        int x1,y1,x2,y2;
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        for(int i=0;i<=n-1;i++)
        {
            int xd,xu;
            scanf("%d%d",&xu,&xd);
            A[i].a.x=xu,A[i].a.y=y1,A[i].b.x=xd,A[i].b.y=y2;
        }
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            int lf=0,rg=n-1;
            while(lf<=rg)
            {
                int mid=(lf+rg)>>1;
                if(check(Point(x,y),mid))lf=mid+1;
                else rg=mid-1;
            }
            pos[lf]++;
        }
        for(int i=0;i<=n;i++)printf("%d: %d\n",i,pos[i]);
        printf("\n");
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值