TOYS(水解析)

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

一个矩形,用一堆连接上下两边的直线隔开,给出一些点坐标(保证不在直线上),问每个区域中包含点的个数。

强行算个解析几何吧……对于每个点,直接判断他是否在直线的左方就好了,如果它在i直线右方,(i+ 1)直线左方,那他就在这个区域了,更快一点用二分就可以,因为是单调的,不过我懒得写,写了个O(n)的。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int n,m,x1,yy1,x2,y2;
int dp[5005];
struct Node
{
    int u,l;
    double k;
}node[5005];
double work(int x,int pnt)
{
    double k = (yy1 - y2)*1.0/(node[pnt].u - node[pnt].l);
    k = k*(node[pnt].u - x);
    k = yy1 - k;
    return k;
}
void prin()
{
    for(int i = 0;i <= n;i++)
        printf("%d: %d\n",i,dp[i]);
    cout<<endl;
}
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\巍巍\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\巍巍\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int kase = 1;
    while(scanf("%d%d%d%d%d%d",&n,&m,&x1,&yy1,&x2,&y2) != EOF)
    {
        if(n == 0)break;
        if(kase != 1)printf("\n");
        kase++;
        memset(dp,0,sizeof(dp));
        for(int i = 1;i <= n;i++)
        {
            scanf("%d%d",&node[i].u,&node[i].l);
            if(node[i].u != node[i].l)
                node[i].k = (yy1 - y2)*1.0/(node[i].u - node[i].l);
        }
        for(int i = 1;i <= m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            bool ok = false;
            for(int j = 1;j <= n;j++)
            {
                if(node[j].u == node[j].l)
                {
                    if(x < node[j].u)
                    {
                        dp[j - 1]++;
                        ok = true;break;
                    }
                }
                else
                {
                    double yy = work(x,j);
                    if(node[j].k < 0 && y < yy)
                    {
                        dp[j - 1]++;ok = true;
                        break;
                    }
                    else if(node[j].k > 0 && y > yy)
                    {
                        dp[j - 1]++;ok = true;
                        break;
                    }
                }
            }
            if(!ok)
                dp[n]++;
            //prin();
        }
        for(int i = 0;i <= n;i++)
            printf("%d: %d\n",i,dp[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值