【HDU1159】Common Subsequence(LCS/DP)

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

题目大意:给出两个序列,请找出这两个序列的最大公共子序列来输出它的个数。
分析:

这里写图片描述

如上图,就可以退出状态方程:当str1[i]==str2[j]时,计数的dp[i][j]就+1.

当两个不等于时,就找他左边或上边最大的 dp[i][j]=max(dp[i-1][j],dp[i][j-1])。

记得先处理第一行和第一列就可以开始递推下去了
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e3+5;

char str1[maxn];
char str2[maxn];
int dp[maxn][maxn];

int main(){
    while(~scanf("%s%s",&str1,&str2)){
        memset(dp,0,sizeof(dp));
        int n = strlen(str1);
        int m = strlen(str2);
        if( str1[0]==str2[0] ){
            dp[0][0]=1;
        }
        for( int i=1 ; i<n ; i++ ){
            if(str1[i]==str2[0])
            dp[i][0] += 1;
            else
            dp[i][0]=max(dp[i-1][0],0);
        }
        for( int i=1 ; i<m ; i++ ){
            if(str1[0]==str2[i])
            dp[0][i] += 1;
            else
            dp[0][i]=max(dp[0][i-1],0);
        }
        for( int i=1 ; i<n ; i++ ){
            for( int j=1 ; j<m ; j++ ){
                if(str1[i]==str2[j]){
                    dp[i][j]=dp[i-1][j-1]+1 ;
                }
                else{
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        /*for( int i=0 ; i<n ; i++ ){
            for( int j=0 ; j<m ; j++ ){
                printf("%d",dp[i][j]);
            }
            cout<<endl;
        }*/
        printf("%d\n",dp[n-1][m-1]);
    }
    return 0;
}
基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip 个人大四的毕业设计、课程设计、作业、经导师指导并认可通过的高分设计项目,评审平均分达96.5分。主要针对计算机相关专业的正在做毕设的学生和需要项目实战练习的学习者,也可作为课程设计、期末大作业。 [资源说明] 不懂运行,下载完可以私聊问,可远程教学 该资源内项目源码是个人的毕设或者课设、作业,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96.5分,放心下载使用! 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),供学习参考。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值