hdu1159 Common Subsequence _LCS最长公共子序列

Common Subsequence

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37282    Accepted Submission(s): 17077

 

 

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

 

 

Sample Input

 

abcfbc abfcab programming contest abcd mnp

 

 

Sample Output

 

4 2 0

 

 

 

 /*
 * 求LCS(最长公共子序列)的长度
 * dp[i][j]:=s[1]...s[i]和t[1]...t[j]对应的LCS的长度
 * 由此,s[1]...s[i]和t[1]...t[j]对应的公共子列可能是
 *     1、当s[i+1]=t[j+1]时,在s[1]...s[i]和t[1]...t[j]的公共子列末尾追加上s[i+1]
 *     2、s[1]...s[i]和t[1]...t[j+1]的公共子列
 *     3、s[1]...s[i+1]和t[1]...t[j]的公共子列
 * 三者中的某一个,所有有如下递推关系成立
 *     dp[i+1][j+1]=dp[i][j]+1 (s[i+1]=t[j+1])
 *     dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]) (其他)
 */

//
// Created by Admin on 2017/3/13.
//
#include<cstdio>
#include <cstring>
#include<algorithm>
using namespace std;

char a[1010],b[1010];
int dp[1010][1010];

int main(){
    while(scanf("%s %s",&a,&b)!=EOF){
        memset(dp,0, sizeof(dp));
        for (int i = 0; i < strlen(a); ++i) {
            for (int j = 0; j < strlen(b); ++j) {
                if(a[i]==b[j])dp[i+1][j+1]=dp[i][j]+1;
                else dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);
            }
        }
        printf("%d\n",dp[strlen(a)][strlen(b)]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值