杭电 hdu 1033 (水题) 但英文特难,题意很难理解

Edge


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2369    Accepted Submission(s): 1510


Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
 

Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.
 

Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.


 

Sample Input
  
  
V AVV
 

Sample Output
  
  
300 420 moveto 310 420 lineto 310 430 lineto stroke showpage 300 420 moveto 310 420 lineto 310 410 lineto 320 410 lineto 320 420 lineto stroke showpage
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1035  1036  1039  1017  1073





题意:就是行走,然后输出走过的点,首先给出两个点(300,420)-> (310,420),然后A是顺时针,V是逆时针走,每次行走都是走10个单位,并且
角度是90度,输出每个转弯点

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <iostream>

using namespace std;

int main ()
{
	char ch[300];
	int i, len;

	while (gets(ch))
	{
		printf ("300 420 moveto\n");               //最开始的两个点是题目本身就存在的,要先输出
		printf ("310 420 lineto\n");
		len = strlen (ch);
		int x = 300, y = 420, x1 = 310, y1 = 420;       //用前后两个点来标记之后的行走

		for (i = 0; i < len; ++i)
		{
			if (ch[i] == 'V'){                          //逆时针时会遇到的情况
				if (x == x1){
					if (y1 < y){
						x = x1;y = y1;x1 += 10;
					}
					else{
						x = x1;y = y1;x1 -= 10;
					}
				}
				else{
					if (x1 > x){
						x = x1;y = y1;y1 += 10;
					}
					else{
						x = x1;y = y1;y1 -= 10;
					}
				}
			}
			else if (ch[i] == 'A')               //顺时针时会遇到的情况
			{
				if (x == x1){
					if (y1 < y){
						x = x1;y = y1;x1 -= 10;
					}
					else{
						x = x1;y = y1;x1 += 10;
					}
				}
				else{
					if (x1 > x){
						x = x1;y = y1;y1 -= 10;
					}
					else{
						x = x1;y = y1;y1 += 10;
					}
				}
			}
			 printf("%d %d lineto\n", x1, y1);
		}
		printf("stroke\nshowpage\n");                     //每一次结束都要输出
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值