Edge

题目名称:Edge

题目链接:Edge

描述

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

输入

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

输出

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

样例输入

V
AVV

样例输出

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

题目大意

给你一个起点和移动方向,第一次所在位置为(300,420),向右移动到(310,420),接下来给定A(顺时针)和V(逆时针)方向旋转继续前进,求点经过的路径

解题思路

分别创建数组dx和dy表示四个方向,下标index表示当前所指向的方向,分别根据顺时针和逆时针来改变下标index所在位置来控制方向

代码如下

#include<iostream>
#include<cstdio>
using namespace std;
int dx[4]={10,0,-10,0};
int dy[4]={0,10,0,-10};
char str[210];

int main()
{
   while(cin>>str){
   	int x=310,y=420;
   	printf("300 420 moveto\n310 420 lineto\n");	
   	int index=0;
   	for(int i=0;str[i];i++){
   	    if(str[i]=='V'){
   	    	index=(index+1)%4;
   	    }else{
   	    	index=(index+3)%4;
   	    }
   	    x+=dx[index];
   	    y+=dy[index];
   	    printf("%d %d lineto\n",x,y);
   	}
   	printf("stroke\nshowpage\n");
   }
   return 0;
}

写在最后

这道题让我想起来去年一道ACM网络赛的题目,和这个类似,可惜当时由于各种原因没写出来,好后悔,不然就可以去参加现场赛了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Microsoft Edge浏览器是微软最新发布的一款不同于传统IE的浏览器,在此前未发布前,微软公布的名称为Spartan浏览器,现如今已正式更名为:Edge浏览器,Microsoft Edge浏览器在最新的Windows 10预览版上已经支持,交互界面更加简洁,还将兼容现有Chrome与Firefox两大浏览器的扩展程序。用户安装的插件将与Chrome与Firefox类似,显示在工具栏上。本站提供Edge浏览器官方下载。 Microsoft Edge浏览器软件特色: 1、支持现代浏览器功能 作为微软新一代的原生浏览器,在保持IE原有的强大的浏览器主功能外,还完美补充了扩展等现代浏览器功能; 2、共享注释 用户可以通过Edge浏览器在网页上撰写或输入注释,并与他人分享; 3、内置微软Contana Edge浏览器内置有人工智能微软Contana,这也是微软创造性的设置。你在使用浏览器的时候,你的个人智能管家会给你更多的搜索和使用建议; 4、设计极简注重实用 Microsoft Edge浏览器的交互界面有点像谷歌Chorme浏览器,比较简洁,这也凸显了微软在Microsoft Edge浏览器的开发上更注重其实用性。 5、依赖于Windows 10 值得一提的是,Edge浏览器依赖于Windows 10系统,因此它无法单独运行。Edge浏览器不支持早期版本的Windows。这可能限制Edge的发展。 Microsoft Edge浏览器功能特点: 1、功能集成 功能按钮主要集中在浏览器右上角,当你上手体验Edge所有基本功能无需多长时间,同样的,当你需要找到什么功能,你也可以在右上角的工具栏处找到。 2、阅读模式 体验过阅读模式,就会发现微软在Edge浏览器的阅读界面上煞费苦心:简介的阅读界面,适合阅读的页面布局,而且没有任何广告,用户还可以随自己心意地调整背景和字体。 3、涂鸦功能 阅读时在页面上做笔记是不少网友的习惯。而Edge想让你们的这种习惯在浏览器上也得以实现。涂鸦功能可以让用户用手指或手写笔直接在页面上涂鸦。你还可以使用钢笔或萤光笔,还可以挑选色彩。 4、微软Contana 微软Edge浏览器内置个人语言助理Cortana,提供多项Cortana设置,方便用户根据自己的习惯使用Cortana。如果你在图书馆或者课堂,你可以关闭Cortana。作为Cortana的后端服务,Bing既支持语音输入,也支持键盘输入。 Microsoft Edge浏览器截图
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值