POJ2262 ZOJ1951 UVa543 Goldbach's Conjecture【哥德巴赫猜想】

509 篇文章 9 订阅
232 篇文章 0 订阅

 

Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 47582 Accepted: 18109

 

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be
written as the sum of two odd prime numbers.


For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

Ulm Local 1998

 

 

 

问题链接POJ2262 ZOJ1951 UVa543 Goldbach's Conjecture

问题简述:(略)

问题分析

  这个问题是验证哥德巴赫猜想,对于输入的n,找出一对差值最大的奇素数。

  使用穷举法来解决这个问题。

  目前POJ使用的C语言编译器,似乎比较古老,在别处可以编译通过的代码,在它这里编译错误。

程序说明:(略)

 

AC的C语言程序如下:

/* POJ2262 ZOJ1951 UVa543 Goldbach's Conjecture */

#include <stdio.h>
#include <math.h>

#define MAXN 1000000

// 试除法判断一个数是否为素数
int isprime(int n)
{
    int end2, i;

    if(n == 3)
        return 1;

    end2 = sqrt(n);
    for(i=3; i<=end2; i+=2) {
        if(n % i == 0)
            break;
    }

    return i > end2 ? 1 : 0;
}

int main(void)
{
    int n;
    int okflag, i;

    while(scanf("%d", &n) != EOF) {
        // 判定结束条件
        if(n == 0)
            break;

        // 寻找素数
        okflag = 0;
        for(i=3; i<=n/2; i+=2)
            if(isprime(i) && isprime(n-i)) {
                okflag = 1;
                break;
            }

        // 输出结果
        if(okflag)
            printf("%d = %d + %d\n", n, i, n-i);
        else
            printf("Goldbach's conjecture is wrong.\n");
    }

    return 0;
}


POJ中,编译错误的代码(第10行):

// 试除法判断一个数是否为素数  
int isprime(int n)  
{  
    if((n & 1) == 0)  // 偶数:n % 2 == 0  
        return 0;  
  
    if(n == 3)  
        return 1;  
  
    int end = sqrt(n), i;  
    for(i=3; i<=end; i+=2) {  
        if(n % i == 0)  
            break;  
    }  
  
    return i > end ? 1 : 0;  
}  

 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值