UVA1587 UVALive3214 POJ2160 Box【水题】

509 篇文章 7 订阅
281 篇文章 4 订阅

Box
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4152 Accepted: 1500

Description

Ivan works at a factory that produces heavy machinery. He has a simple job -- he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.

Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes -- he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake.
Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input

Input consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 <= w, h <= 10 000) -- width and height of the pallet in millimeters respectively.

Output

Write a single word "POSSIBLE" to the output file if it is possible to make a box using six given pallets for its sides. Write a single word "IMPOSSIBLE" if it is not possible to do so.

Sample Input

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683

Sample Output

POSSIBLE

Source


Regionals 2004 >> Europe - Northeastern


问题链接UVA1587 UVALive3214 POJ2160 Box

问题简述:给出六组整数,问能否构成六面体。

问题分析:(略)

程序说明:这个题用C语言做的毫无技术含量,也许用C++来写会好一些。


AC的C语言程序如下:

/* UVA1587 UVALive3214 POJ2160 Box */

#include <stdio.h>

#define MAXN 6

struct {
    int w, h;
    int count;
} a[MAXN];
int acount;

void swap(int n)
{
    if(a[n].w > a[n].h) {
        int temp = a[n].w;
        a[n].w = a[n].h;
        a[n].h = temp;
    }
}

int checkok()
{
    if(a[0].w == a[1].w && a[0].h == a[2].w && a[1].h == a[2].h)
        return 1;
    else if(a[0].w == a[1].w && a[0].h == a[2].h && a[1].h == a[2].w)
        return 1;
    else if(a[0].w == a[1].h && a[0].h == a[2].w && a[1].w == a[2].h)
        return 1;
    else if(a[0].w == a[1].h && a[0].h == a[2].h && a[1].w == a[2].w)
        return 1;
    else if(a[0].h == a[1].w && a[0].w == a[2].w && a[1].h == a[2].h)
        return 1;
    else if(a[0].h == a[1].w && a[0].w == a[2].h && a[1].h == a[2].w)
        return 1;
    else if(a[0].h == a[1].h && a[0].w == a[2].w && a[1].w == a[2].h)
        return 1;
    else if(a[0].h == a[1].h && a[0].w == a[2].h && a[1].w == a[2].w)
        return 1;
    else
        return 0;
}

int main(void)
{
    int i, j;

    while(scanf("%d%d", &a[0].w, &a[0].h) != EOF) {
        a[0].count = 1;
        swap(0);

        acount = 1;
        for(i=1; i<MAXN; i++) {
            scanf("%d%d", &a[acount].w, &a[acount].h);
            a[acount].count = 1;
            swap(acount);

            /* 去重复 */
            for(j=0; j<acount; j++)
                if(a[j].w == a[acount].w && a[j].h == a[acount].h && a[j].count != 2) {
                    a[j].count++;
                    acount--;
                    break;
                }
            acount++;
        }

        if(acount != 3)
            printf("IMPOSSIBLE\n");
        else if(checkok())
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }

    return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值