Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 2192 | Accepted: 938 |
Description
A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.
The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h. Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.
Input
There are two lines in the input file, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.
Each string is non-empty and its length does not exceed 100.
Output
Write a single integer number to the output file — the minimal length of the stripe required to cut off given sections.
Sample Input
sample input #1 2112112112 2212112 sample input #2 12121212 21212121 sample input #3 2211221122 21212
Sample Output
sample output #1 10 sample output #2 8 sample output #3 15
Source
Regionals 2006 >> Europe - Northeastern
问题链接:UVA1588 UVALive3712 POJ3158 Kickdown。
问题简述:(略)
问题分析:
这个问题需要注意的是两个字符串哪个在左边都有可能。另外,两个字符串匹配的时候,同一位置不能同时为'2'。
程序说明:
循环控制条件需要小心处理。
AC的C语言程序如下:
/* UVA1588 UVALive3712 POJ3158 Kickdown */
#include <stdio.h>
#include <string.h>
#define MIN(x, y) (((x)>(y))?(y):(x))
#define MAXN 100
char s[MAXN], t[MAXN];
int main(void)
{
int slen, tlen, ans1, ans2, i, j;
while(scanf("%s", s) != EOF) {
scanf("%s", t);
slen = strlen(s);
tlen = strlen(t);
/* s left, t right */
for(i=0; i<slen; i++) {
for(j=0; j<tlen && i+j<slen; j++) {
if(s[i+j] == '2' && t[j] == '2')
break;
}
if(j == tlen || i+j == slen)
break;
}
ans1 = i + tlen;
if(ans1 < slen)
ans1 = slen;
/* t left, s right */
for(j=0; j<tlen; j++) {
for(i=0; i<slen && j+i<tlen; i++) {
if(t[j+i] == '2' && s[i] == '2')
break;
}
if(i == slen || j+i == tlen)
break;
}
ans2 = j + slen;
if(ans2 < tlen)
ans2 = tlen;
printf("%d\n", MIN(ans1, ans2));
}
return 0;
}