UVALive3045 POJ2000 ZOJ2345 Gold Coins【水题】

281 篇文章 4 订阅
232 篇文章 0 订阅

 

Gold Coins

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23895 Accepted: 14903

 

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer. 

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1). 

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

Source

Rocky Mountain 2004

 

Regionals 2004 >> North America - Rocky Mountain

 

 

问题链接UVALive3045 POJ2000 ZOJ2345 Gold Coins

题意简述

  骑士第1天获得1个金币,之后的2天获得2个金币,之后的3天获得3个金币,......,之后的i天获得i个金币,......。问到第n天总共获得多少个金币。

问题分析

  这是一个数列求和问题,用程序解决比用数学解决方便很多。

程序说明

  用数组ans[]存储金币之和,即ans[i]为到第i天为止金币之和,设置ans[i]的初始值为0(程序员要尽量避免使用缺省值,以免得到意外的计算结果,除非缺省值绝对有保障)。

  ZOJ的输入输出数据格式略有不同,参见AC程序。

 

AC的C语言程序(UVALive和POJ)如下:

/* UVALive3045 POJ2000 Gold Coins */

#include <stdio.h>

#define MAXN 10000

int ans[MAXN+1] = {0};

void maketable()
{
    int i, j, k;

    j = 1;  /* Ai, S=1,2,2,3,3,3,4,4,4,4,...... */
    k = 1;  /* 同值计数变量:j值够j个(用k来计数, k=j时)则j增1 */
    for (i=1; i<=MAXN; i++){
        ans[i] = j + ans[i - 1];
        if (k == j){
            j++;
            k = 0;
        }
        k++;
    }
}

int main(void)
{
    maketable();

    int n;
    while(scanf("%d", &n) != EOF && n != 0)
        printf("%d %d\n", n, ans[n]);

    return 0;
}

AC的C语言程序(ZOJ)如下:

/* ZOJ2345 Gold Coins */

#include <stdio.h>

#define MAXN 10000

int ans[MAXN+1] = {0};

void maketable()
{
    int i, j, k;

    j = 1;  /* Ai, S=1,2,2,3,3,3,4,4,4,4,...... */
    k = 1;  /* 同值计数变量:j值够j个(用k来计数, k=j时)则j增1 */
    for (i=1; i<=MAXN; i++){
        ans[i] = j + ans[i - 1];
        if (k == j){
            j++;
            k = 0;
        }
        k++;
    }
}

int main(void)
{
    maketable();

    int t, n;
    scanf("%d", &t);
    while(t--) {
        while(scanf("%d", &n) != EOF && n != 0)
            printf("%d %d\n", n, ans[n]);
        if(t) printf("\n");
    }

    return 0;
}

 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值