UVA489 Hangman Judge【模拟】

  In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

1. The contestant tries to solve to puzzle by guessing one letter at a time.

2. Every time a guess is correct, all the characters in the word that match the guess will be “turned over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will be counted as “solved”.

3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.


4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.

5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.

6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

  Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.

You lose.

You chickened out.

Sample Input

1

cheese

chese

2

cheese

abcdefg

3

cheese

abcdefgij

-1

Sample Output

Round 1

You win.

Round 2

You chickened out.

Round 3

You lose.


问题链接UVA489 Hangman Judge

问题简述:(略)

问题分析:这是一个模拟题。

程序说明

  程序中定义了若干宏定义,使得程序可阅读性增强。

  函数guess()中的逻辑需要认真考虑,保证更加合理快速。



AC的C语言程序如下:

/* UVA489 Hangman Judge */

#include <stdio.h>
#include <string.h>

#define TRUE  1
#define FALSE 0
#define MAXN 128

char s[MAXN], t[MAXN];
int win, lose, chance, left, lens, lent;

void guess(char c)
{
    int bad, i;

    bad = TRUE;
    for(i=0; i<lens; i++)
        if(s[i] == c) {
            if(--left == 0) {
                win = 1;
                return;
            }
            s[i] = ' ';
            bad = FALSE;
        }

    if(bad)
        if(--chance == 0)
            lose = TRUE;
}

int main(void)
{
    int round, i;

    while(scanf("%d%s%s", &round, s, t) != EOF && round != -1) {
        printf("Round %d\n", round);

        left = lens = strlen(s);
        lent = strlen(t);

        win = lose = FALSE;
        chance = 7;

        for(i=0; i<lent; i++) {
            guess(t[i]);
            if(win || lose)
                break;
        }

        if(win)
            printf("You win.\n");
        else if(lose)
            printf("You lose.\n");
        else
            printf("You chickened out.\n");
    }

    return 0;
}



  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值