POJ1979 HDU1312 ZOJ2165 Red and Black【DFS】

509 篇文章 6 订阅

 

Red and Black

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 38045 Accepted: 20643

 

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Japan 2004 Domestic

 

问题链接POJ1979 HDU1312 ZOJ2165 Red and Black

 

题意简述

  输入正整数w和h,w为列数,h为行数。输入h×w矩阵 (1 <= h <= 20; 1 <= w <= w),其中'.'代表可到达,'#'代表不可到达,'@'代表开始点。问从'@'开始可以到达最多多少个点。

问题分析

  本题可以使用深度优先搜索求解,用广度优先搜索也可以求解,差别不大。需要注意的是'@'也算一个可以到达的点。

  采用递归实现的DFS程序往往代码更加简洁,所以增加一个递归实现的DFS的版本。输入处理也做了简化。

程序说明

1.方向数组 使用方向数组后,各个方向的试探的程序就会变得简洁了,用循环处理即可。

2.避免重复搜索 将搜索过的节点设置为'#'(陆地),可以避免重复搜索,简化程序逻辑。

3.设置边界 通过设置边界,可以免去矩阵(二维数组)的边界判断,简化了程序逻辑。

该问题与图遍历中寻找联通块问题基本上是同构的,算法思路一致。

每当找到一个相邻的'.',只需要计数加一,并且使用DFS算法把与其相邻的4个相邻的点继续判断。

 

AC的C语言程序(递归DFS)如下:

/* POJ1979 HDU1312 ZOJ2165 Red and Black */

#include <stdio.h>

#define N 20
int h, w;
char b[N][N + 1];

int dfs(int x, int y)
{
    if(x < 0 || x >= h || y < 0 || y >= w)
        return 0;
    else if(b[x][y] == '#')
        return 0;
    else {
        b[x][y] = '#';
        return 1 + dfs(x - 1, y) + dfs(x + 1, y) + dfs(x, y - 1) + dfs(x, y + 1);
    }
}

int main(void)
{
    int i, j;
    while(scanf("%d%d", &w, &h) != EOF && (h || w)) {
        for(i = 0; i < h; i++)
            scanf("%s", b[i]);

        for(i = 0; i < h; i++)
            for(j = 0; j < w; j++)
                if(b[i][j] == '@')
                    printf("%d\n", dfs(i, j));
    }

    return 0;
}

 

AC的C语言程序如下:

/* POJ1979 HDU1312 ZOJ2165 Red and Black */

#include <stdio.h>
#include <string.h>

#define K 4
int drow[] = {0, 0, -1, 1};
int dcol[] = {-1, 1, 0 , 0};

#define N 20
char b[N+2][N+2];
int cnt;

int dfs(int row, int col)
{
    int i;
    for(i=0; i<K; i++) {
        int nextrow = row + drow[i];
        int nextcol = col + dcol[i];
        if(b[nextrow][nextcol] == '.') {
            cnt++;
            b[nextrow][nextcol] = '#';
            dfs(nextrow, nextcol);
        }
    }
    return cnt;
}


int main(void)
{
    int h, w, i, j;

    while(scanf("%d%d", &w, &h) != EOF && (h || w)) {
        memset(b, 0, sizeof(b));      // 清零:边界清零

        for(i = 1; i <= h; i++)
            scanf("%s", b[i] + 1);

        for(i = 0; i <= h; i++)
            b[i][0] = '#';
        for(i = 0; i <= w; i++)
            b[0][i] = b[h + 1][i] = '#';


        for(i = 1; i <= h; i++)
            for(j = 1; j <= w; j++)
                if(b[i][j] == '@') {
                    cnt = 1;
                    printf("%d\n", dfs(i, j));
                    break;
                }
    }

    return 0;
}

 

 

 

 

 

 

  • 5
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值