POJ2388 HDU1157 Who's in the Middle【中位数+排序+水题】

509 篇文章 9 订阅
73 篇文章 3 订阅
Who's in the Middle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44169 Accepted: 25455

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

Hint

INPUT DETAILS:

Five cows with milk outputs of 1..5

OUTPUT DETAILS:

1 and 2 are below 3; 4 and 5 are above 3.

Source



问题链接:POJ2388 HDU1157 Who's in the Middle

问题简述

  输入n个数,找出一个数,满足至少有一半大于或等于它,并且有一半小于或等于它。

问题分析

  一个求中间数的问题。

程序说明

  这个程序与HDU1157应该是同一个问题,在POJ2388中提交可以通过,但是在HDU1157中提交出现Wrong Answer。经过调查,HDU1157要求输入多组测试用例,修改程序后就通过的,参见后一个代码。


参考链接HDU1157 POJ2338 Who's in the Middle


AC的C++语言程序如下(HDU1157未AC):

/* POJ2388 Who's in the Middle */

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 10000;
int a[N];

int main()
{
    int n;

    // 输入数据
    cin >> n;
    for(int i=0; i<n; i++)
        cin >> a[i];

    // 排序
    sort(a, a+n);

    // 输出结果
    cout << a[n / 2] << endl;

    return 0;
}


AC的C++语言程序如下(两者都AC):

/* POJ2388 HDU1157 Who's in the Middle */

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 10000;
int a[N];

int main()
{
    int n;

    // 输入数据
    while(cin >> n) {
        for(int i=0; i<n; i++)
            cin >> a[i];

        // 排序
        sort(a, a+n);

        // 输出结果
        cout << a[n / 2] << endl;
    }

    return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值