POJ3187 Backward Digit Sums【全排列】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7633 Accepted: 4397

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:  

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.  

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample:  

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source


问题链接POJ3187 Backward Digit Sums

问题简述参见上文。

问题分析计算规模比较小,用全排列和暴力解决问题。三角形的计算直接模拟即可,关键是递推计算公式要正确。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ3187 Backward Digit Sums */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 20;
int a[N], grid[N][N];

bool check(int n, int sum)
{
    for(int i=0; i<n; i++)
        grid[0][i] = a[i];
    for(int i=1; i<n; i++)
        for(int j=0; j<n-i; j++)
            grid[i][j] = grid[i - 1][j] + grid[i - 1][j + 1];
    return grid[n - 1][0] == sum;
}

int main()
{
    int n, sum;

    while(scanf("%d%d", &n, &sum) != EOF) {
        for(int i=0; i<n; i++)
            a[i] = i + 1;

        do {
            if(check(n, sum)) {
                for(int i=0; i<n; i++) {
                    if(i != 0)
                        printf(" ");
                    printf("%d", a[i]);
                }
                printf("\n");
                break;
            }
        } while(next_permutation(a, a + n));
    }

    return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值