HDU1395 ZOJ1489 2^x mod n = 1【暴力法+数论】

232 篇文章 0 订阅
67 篇文章 0 订阅

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17824    Accepted Submission(s): 5582


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

Input
One positive integer on each line, the value of n.
 

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 

Sample Input
  
  
2 5
 

Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1
 

Author
MA, Xiao
 

Source


问题链接HDU1395 ZOJ1489 2^x mod n = 1

问题简述:对于输入的n,求满足 2^x mod n = 1的最小正整数x。

问题分析:若n是偶数或者1则无解,否则用暴力法来解。这个题是一个水题。

程序说明(略)

题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* HDU1395 ZOJ1489 2^x mod n = 1 */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n;
    while(scanf("%d", &n) != EOF) {
        if(n % 2 == 0 || n == 1)
            printf("2^? mod %d = 1\n", n);
        else {
            int t = 2, x = 1;
            while(t != 1) {
                t *= 2;
                t %= n;
                x++;
            }
            printf("2^%d mod %d = 1\n", x, n);
        }
    }

    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值