POJ2080 ZOJ2420 Calendar【日期+模拟】

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14463 Accepted: 5171

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.  
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.  
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.  
You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday

Source


问题链接POJ2080 ZOJ2420 Calendar

问题简述:(略)

问题分析

  这个问题是根据输入的天数(从2000年1月1日起),计算日期和星期。

  用模拟法比较简单,先一年一年过,然后一个月一个月过,最后年月日就算出来了。

程序说明

  需要注意day+1,也就是说每个月的第1天是1日。

  另外,还需要知道2000年1月1日是星期几才能算出星期几。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ2080 ZOJ2420 Calendar */

#include <iostream>
#include <stdio.h>

using namespace std;

const char *DAYS[] = {"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"};
const int MDAYS[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};

int leapyear(int year)
{
    return ( ((year%4==0) && (year%100!=0)) || (year%400==0) ) ? 1 : 0;
}

int monthdays(int year, int month)
{
    return month == 2 ? MDAYS[month] + leapyear(year) : MDAYS[month];
}

int main()
{
    int days, year, month, day, y, m;

    while(~scanf("%d", &days) && days != -1) {
        day = days;

        // 计算年:一年一年算
        for(year = 2000; ; year++) {
            y = 365 + leapyear(year);
            if(day < y)
                break;
            day -= y;
        }

        // 计算月:一个月一个月算
        for(month=1; ;month++) {
            m = monthdays(year, month);
            if(day < m)
                break;
            day -= m;
        }

        printf("%d-%02d-%02d %s\n", year, month, day + 1, DAYS[(6 + days) % 7]);
    }

    return 0;
}






  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值