UVA120 Stacks of Flapjacks【排序模拟】

96 篇文章 5 订阅
55 篇文章 6 订阅

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

  This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

  Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake’s diameter. All pancakes in a stack have different diameters.

  Sorting a stack is done by a sequence of pancake “flips”. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) all the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

  A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

  For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

8 7 2

4 6 5

6 4 8

7 8 4

5 5 6

2 2 7

The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a ‘0’ (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5

5 4 3 2 1

5 1 2 3 4

Sample Output

1 2 3 4 5

0

5 4 3 2 1

1 0

5 1 2 3 4

1 2 0


问题链接UVA120 Stacks of Flapjacks

问题简述

  一摞煎饼,从下面拿起来一张,把该张上面的所有馅饼反转,求最后使得馅饼从小到大的最小的步数。

问题分析

  这是一个排序模拟问题,用贪心法解决。

  每次都把没排好序的最大数反转到最上面,然后再一次反转到最下面,最多需要2n步把所有馅饼排好序。模拟指令的执行过程,内容包括指令、寄存器和存储器。

程序说明

  程序中使用了字符串流,程序处理比较方便。


题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* UVA120 Stacks of Flapjacks */

#include <bits/stdc++.h>

using namespace std;

const int N = 30;
int a[N];

void flip(int n, int p)
{
    for(int i=0; i<p-i; i++)
        swap(a[i], a[p - i]);
    printf("%d ", n - p);
}

int main()
{
    string s;
    while(getline(cin, s)) {
        stringstream ss(s);
        int n = 0;
        while(ss >> a[n])
            n++;

        cout << s << endl;
        for(int i=n-1; i>0; i--) {
            int pos = max_element(a, a + i + 1) - a;
            if(pos == i)
                continue;
            if(pos > 0)
                flip(n, pos);
            flip(n, i);
        }
        printf("0\n");
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值