POJ1083 HDU1050 ZOJ1029 UVALive2326 Moving Tables【序列+最值】

509 篇文章 9 订阅
281 篇文章 4 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33026 Accepted: 11063

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.  

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.  

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.  
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd  
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source


Regionals 2001 >> Asia - Taejon


问题链接POJ1083 HDU1050 ZOJ1029 UVALive2326 Moving Tables

问题简述

  走廊上共有400个房间,两边各有200个房间,房间之间要搬桌子,走廊每次(同一时间)只能通过一张桌子,每次搬动桌子占用10分钟,问搬动那些桌子最少需要多长时间。

问题分析

  把走廊的各个点编一个号,每次搬运桌子都会占用走廊,针对占用的走廊编号做个统计,再取最大值就可以了。

程序说明

  输入的房间号对,不能保证先小后大,需要做个比较。

  400个房间的走廊,编号只有1-200。数组下标是从0开始的,多声明一个元素计算就方便了。房间号与走廊号需要一个公式进行映射。

  统计时直接加10,最后就不用做加法了。

题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* POJ1083 HDU1050 ZOJ1029 UVALive2326 Moving Tables */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 200;
int corridor[N + 1];

int main()
{
    int t, n, start, end;

    scanf("%d", &t);
    while(t--) {
        memset(corridor, 0, sizeof(corridor));

        scanf("%d", &n);
        for(int i=1; i<=n; i++) {
            scanf("%d%d", &start, &end);

            if(start > end)
                swap(start, end);
            for(int j=(start + 1) / 2; j<=(end + 1) / 2; j++)
                corridor[j] += 10;
        }

        int maxtime = 0;
        for(int i=1; i<=N; i++)
            maxtime = max(maxtime, corridor[i]);

        printf("%d\n", maxtime);
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值