POJ1309 HDU1346 ZOJ1269 UVA616 UVALive5462 Coconuts, Revisited【暴力+模拟】

708 篇文章 18 订阅
509 篇文章 6 订阅

Coconuts, Revisited

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2171 Accepted: 885

Description

The short story titled Coconuts, by Ben Ames Williams, appeared in the Saturday Evening Post on October 9, 1926. The story tells about five men and a monkey who were shipwrecked on an island. They spent the first night gathering coconuts. During the night, one man woke up and decided to take his share of the coconuts. He divided them into five piles. One coconut was left over so he gave it to the monkey, then hid his share and went back to sheep. 

Soon a second man woke up and did the same thing. After dividing the coconuts into five piles, one coconut was left over which he gave to the monkey. He then hid his share and went back to bed. The third, fourth, and fifth man followed exactly the same procedure. The next morning, after they all woke up, they divided the remaining coconuts into five equal shares. This time no coconuts were left over. 

An obvious question is "how many coconuts did they originally gather?" There are an infinite number of answers, but the lowest of these is 3,121. But that's not our problem here. 

Suppose we turn the problem around. If we know the number of coconuts that were gathered, what is the maximum number of persons (and one monkey) that could have been shipwrecked if the same procedure could occur? 
 

Input

The input will consist of a sequence of integers, each representing the number of coconuts gathered by a group of persons (and a monkey) that were shipwrecked. The sequence will be followed by a negative number.

Output

For each number of coconuts, determine the largest number of persons who could have participated in the procedure described above. Display the results similar to the manner shown below, in the Expected Output. There may be no solution for some of the input cases; if so, state that observation.

Sample Input

25
30
3121
-1

Sample Output

25 coconuts, 3 people and 1 monkey
30 coconuts, no solution
3121 coconuts, 5 people and 1 monkey

Source

North Central North America 1997


Regionals 1997 >> North America - North Central NA

 

问题链接POJ1309 HDU1346 ZOJ1269 UVA616 UVALive5462 Coconuts, Revisited

问题描述:(略)

问题分析

  这是一个与递推有关的问题,不过要把递推的数学式写出来还是要费点功夫的。

  为了简单,就模拟吧。开始的时候有n个椰子,可以假设有m个人,按照题意把每个人做的事情都模拟一边就好了。每一步都要保证是合理的。有m个人,n个椰子,其中一个给了猴子,并且分成m份,把自己的那一份藏起来,所以必须满足(n-1)%m==0。然后,椰子数量就变少了,少了(n-1)/m+1个。

  按理说,给定n个椰子,那有多少人呢?应该从人数m=n-1开始试探,看看能不能分到最后(题目中求的是最多的人数)。然而,如果从m=n-1开始的话,UVALive5462会TLE。那就假定人数不多于100人看看,程序中的100就是这么来的。程序中的M只能找个合适的值试一下。

程序说明:(略)

参考链接:(略)

题记:没有想出好办法就暴力或模拟,这两招都用上了。

 

AC的C++语言程序如下:

/* POJ1309 HDU1346 ZOJ1269 UVALive5462 Coconuts, Revisited */

#include <iostream>
#include <stdio.h>

using namespace std;

const int M = 100;

int main()
{
    int n;
    while(~scanf("%d", &n) && n >= 0) {
        bool flag = false;
        int m;
        for(m = M; m >= 2; m--) {
            int sum = n, j;
            for(j = 1; j <= m; j++) {
                if((sum - 1) % m != 0)
                    break;
                sum -= 1 + (sum - 1) / m;
            }
            if(j > m && sum % m == 0) {
                flag = true;
                break;
            }
        }

        if(flag)
            printf("%d coconuts, %d people and 1 monkey\n", n, m);
        else
            printf("%d coconuts, no solution\n", n);
    }

    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,这个问题属于技术问题。以下是一个简单的Python模拟登录POJ提交代码并抓取评测结果的代码示例: ```python import requests # 登录POJ,获取cookie def login(username, password): s = requests.Session() login_url = "http://poj.org/login" login_data = { "user_id1": username, "password1": password, "B1": "login", "url": "/" } s.post(login_url, data=login_data) return s # 提交代码 def submit_code(s, problem_id, language, source_code): submit_url = "http://poj.org/submit" submit_data = { "problem_id": problem_id, "language": language, "source": source_code } s.post(submit_url, data=submit_data) # 获取评测结果 def get_result(s, run_id): status_url = "http://poj.org/status" params = { "user_id": "", "result": "", "language": "", "top": run_id } r = s.get(status_url, params=params) table_start = r.text.find("<table cellpadding=0 cellspacing=0 border=0 width=100%>") table_end = r.text.find("</table>", table_start) table_html = r.text[table_start:table_end + 8] return table_html # 使用示例 username = "your_username" password = "your_password" problem_id = "1000" language = "G++" source_code = """ #include <iostream> using namespace std; int main() { int a, b; cin >> a >> b; cout << a + b << endl; return 0; } """ s = login(username, password) submit_code(s, problem_id, language, source_code) table_html = get_result(s, "12345678") # 替换实际提交的run id print(table_html) ``` 其中,`login`函数模拟登录POJ并返回一个`Session`对象,`submit_code`函数提交代码,`get_result`函数获取评测结果。你可以根据实际需要修改代码中的`username`、`password`、`problem_id`、`language`和`source_code`等参数,并替换`get_result`函数中的`run_id`。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值