hdu 4055 Number String ( DP 绝对位置转化为相对位置 )

Number String

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1013    Accepted Submission(s): 438


Problem Description
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.
 

Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.
 

Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.
 

Sample Input
  
  
II ID DI DD ?D ??
 

Sample Output
  
  
1 2 2 1 3 6
Hint
Permutation {1,2,3} has signature "II". Permutations {1,3,2} and {2,3,1} have signature "ID". Permutations {3,1,2} and {2,1,3} have signature "DI". Permutation {3,2,1} has signature "DD". "?D" can be either "ID" or "DD". "??" gives all possible permutations of length 3.
 

Author
HONG, Qize
 

Source


思路:
DP,将绝对位置转化为相对位置。
状态:dp[i][j]-排列个数   i-长度为i字符串  j-最后一个数的相对位置为j   
从i-1到i时插入一个相对位置为j的数时,将i-1时的数的相对位置>=j的相对位置都加1处理。
方程:
'I':    dp[i][j]=∑dp[i-1][k]  (1<=k<j )
'D':     dp[i][j]=dp[i-1][k]  ( j<=k<i )
'?':      dp[i][j]=dp[i-1][k]  (1<=k<i)

ps:对k就不用再套个循环了,用前缀和优化就够了。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 1005
#define INF 0x3f3f3f3f
#define mod 1000000007
using namespace std;

typedef long long ll;
ll ans;
ll dp[maxn][maxn],sum[maxn][maxn];
char s[maxn];

void solve()
{
    int i,j,k,len;
    len=strlen(s);
    for(i=1;i<len;i++)
    {
        sum[i][0]=0;
    }
    dp[1][1]=sum[1][1]=1;
    for(i=2;i<len;i++)
    {
        for(j=1;j<=i;j++)
        {
            if(s[i]=='I') dp[i][j]=sum[i-1][j-1];
            else if(s[i]=='D') dp[i][j]=(sum[i-1][i-1]-sum[i-1][j-1]+mod)%mod; // 注意sum[i-1][i-1]-sum[i-1][j-1]可能为负数 带模的运算可能把大的变小了
            else dp[i][j]=sum[i-1][i-1];
            sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;
        }
    }
    ans=sum[len-1][len-1];
}
int main()
{
    int i,j;
    while(~scanf("%s",s+2))
    {
        s[0]=s[1]=' ';
        solve();
        printf("%I64d\n",ans);
    }
    return 0;
}



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的高校科研信息管理系统实现了操作日志管理、字典管理、反馈管理、公告管理、科研成果管理、科研项目管理、通知管理、学术活动管理、学院部门管理、科研人员管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让高校科研信息管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值