poj 2299 Ultra-QuickSort (树状数组解法)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 32746 Accepted: 11691

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
ps:刚学了下树状数组  所以这题用树状数组做的  不过这题正规方法应该用归并排序做的 
    各位亲们 想了解 树状数组的可以看一下 不想的就直接pass哈
 
#include<cstdio>
#include <cstring>
#include <algorithm>
#define maxn 500005
using namespace std;

int n;
__int64 ans;
int a[maxn];
struct Tnode
{
    int num;
    int val;
}node[maxn];

int lowbit(int v)
{
    return v&(-v);
}
void update(int v)
{
    for(int i=v; i<=maxn-5; i+=lowbit(i))
    {
        a[i]++;
    }
}
int getsum(int v)
{
    int sum=0;
    for(int i=v; i>0; i-=lowbit(i))
    {
        sum+=a[i];
    }
    return sum;
}
bool cmp1(const Tnode &x,const Tnode &y)
{
    return x.val<y.val;
}
bool cmp2(const Tnode &x,const Tnode &y)
{
    return x.num<y.num;
}
int main()
{
    int i,preval,temp;
    while(scanf("%d",&n),n)
    {
        for(i=1; i<=n; i++)
        {
            scanf("%d",&node[i].val);
            node[i].num=i;
        }
        sort(node+1,node+n+1,cmp1);
        preval=-1;
        for(i=1; i<=n; i++)         // 此循环用来离散化 a[i] 将其范围缩小到maxn内
        {                           // 注意这里不能简单地 node[i].val=i;
            temp=node[i].val;
            if(node[i].val==preval)
            {
                node[i].val=node[i-1].val;
            }
            else node[i].val=i;     
            preval=temp;

        }
        sort(node+1,node+n+1,cmp2);
        memset(a,0,sizeof(a));
        ans=0;
        for(i=1; i<=n; i++)
        {
            ans+=getsum(maxn-5)-getsum(node[i].val);
            update(node[i].val);
        }
        printf("%I64d\n",ans);   //  坑爹 原来逆序数可以很大很大 要用__int64保存  不然会WA
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值