HDU2317 Convert Kilometers to Miles 【简单题】

Convert Kilometers to Miles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 584    Accepted Submission(s): 391


Problem Description
This year, Bruce Force spends his vacation in Flagstaff, Arizona, where he wants to practice for his next half marathon (a race over 21 km). At his first training he runs to his friend Greedy Gonzales' home which is 21 miles away from Flagstaff.
Arriving there, he is very tired and realizes that 21 miles are much more than 21 km. Greedy Gonzales tells him that 21 km equals 13 miles. 21, 13? Bruce realizes immediately that there must be a deeper relation! Both, 13 and 21 are Fibonacci numbers!
Fibonacci numbers can be defined as follows:

F1 = 1
F2 = 2
Fn+1 = Fn+Fn-1 for n>1.

Bruce has just learned about the Fibonacci number system at his university. Each positive integer x can be written as the sum of different Fibonacci numbers, so this means that there exists numbers k and b1, b2, ..., bk such that x = ∑i=1..k bi * Fi, where bk = 1 and bi (1 ≤ i < k) is either 0 or 1. In short, we can write the representation as: b(x) = (bk, bk-1, ..., b1). To make the representation unique, we require that bi * bi-1 = 0 for all i > 1.
For example 21 can be represented as (1,0,0,0,0,0,0) and 13 as (1,0,0,0,0,0) in the Fibonacci system. Bruce notices that one can convert a distance x in kilometers into a corresponding distance y to miles as follows: First, write down x in its Fibonacci system representation b(x). Second, shift the bits of b(x) one position to the right (the last bit is deleted) and get b(y). Third, calculate y from b(y) by evaluating the sum given above.
For example, the number 42 written in the Fibonacci system is (1,0,0,1,0,0,0,0). In step two we would shift the bits one position to the right and get (1,0,0,1,0,0,0). In the third step, we would calculate 0*1 + 0*2 + 0*3 + 1*5 + 0*8 + 0*13 + 1*21 = 26.
Now it's your turn to write a program for Bruce that converts kilometers into miles according to Bruce's algorithm.

Input
The first line of the input contains t, the number of distances Bruce wants to convert from kilometers to miles (0<t<25000). Each of the next t lines contains an integer distance x (2 < x < 25000) in kilometers.

Output
For each distance x in kilometers output the distance y in miles calculated according to Bruce's algorithm.

Sample Input
  
  
5 42 100 180 300 360

Sample Output
  
  
26 62 111 185 222
 每一个正整数可以写成不同的Fibonacci数的总和 , 倒着找
#include <stdio.h>
#include <string.h>
int Fib[30]={1,1,2};
bool flag[30];
int num,sum;
void f()
{
	int i;
	for(i=3;i<25;i++)
	{
		Fib[i]=Fib[i-1]+Fib[i-2];
	//	printf("%d\n",Fib[i]);
	}
}
int main()
{
	f();
	int t;
	int ans;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		scanf("%d",&num);
		for(i=24;num>0;i--)
		{
			if(num>=Fib[i])
			{
				num-=Fib[i];
				if(i!=1)
					ans+=Fib[i-1];
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值