PAT (Advanced Level) 1047. Student List for Course (25) 哈希,排序,string与char数组的转换

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
写一个哈希表vector<vector<string> > hashx(K+1);hashx[i]存储课程i的所有学生。
由于输出时学生要按照姓名排序。有两种方法,一是哈希后,对哈希表的单个元素,即单个课程内的学生进行排序。二是先对输入数据进行排序,然后进行哈希,这种方法只需要排序一次,效率较高。
为避免超时,输入输出使用C语言写。注意C语言char数组与C++string的相互转换,用char数组初始化string即可转为string,而strcpy(ch,s.c_str());可将string对象s转为char数组ch。
/*2015.7.26cyq*/
#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <cstring>
using namespace std;

struct stu{
	string name;		//学生姓名
	vector<int> course; //课程
	bool operator < (const stu &a)const{
		return name<a.name;
	}
};
int main(){
	int N,K;
	scanf("%d%d",&N,&K);
	vector<stu> data;
	int C;
	int x;
	char ch[5];
	while(N--){
		stu tmp;
		scanf("%s",ch);
		tmp.name=ch;	//char数组转string
		scanf("%d",&C);
		while(C--){
			scanf("%d",&x);
			tmp.course.push_back(x);
		}
		data.push_back(tmp);
	}
	sort(data.begin(),data.end());//对学生按照字母进行排序
	
	vector<vector<string> > hashx(K+1);//hashx[i]存储课程i的所有学生
	for(auto it=data.begin();it!=data.end();it++){
		for(auto ik=(*it).course.begin();ik!=(*it).course.end();ik++){
			hashx[*ik].push_back((*it).name);
		}
	}
	for(int i=1;i<=K;i++){
		if(!hashx[i].empty()){//该课程有学生
			printf("%d %d\n",i,hashx[i].size());
			for(auto it=hashx[i].begin();it!=hashx[i].end();++it){
				strcpy(ch,(*it).c_str());//string转char数组
				printf("%s\n",ch);
			}
		}else{
			printf("%d 0\n",i);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值