PAT (Advanced Level) 1044. Shopping in Mars (25) 找符合要求的连续子数组,贪心

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5
贪心算法。可以看成一条贪吃蛇从左往右。头部尽可能的向右延伸直到钱够,若此方案最便宜,则记下头部和尾部位置。一旦钱够,尾部一点点收缩(同时判断方案是否最便宜),尾部收缩到钱不够后,头部继续向右延伸直到钱够。当头部到达终点,且尾部收缩到钱不够后,退出循环。复杂度O(N)。
/*2015.7.25cyq*/
#include <iostream>
#include <vector>
using namespace std;
//贪心算法
int main(){
	int N,M;
	scanf("%d%d",&N,&M);
	vector<int> ivec(N);
	for(int i=0;i<N;i++)
		scanf("%d",&ivec[i]);

	int MIN=2147483647;
	vector<pair<int,int> > result;
	int left=0,right=-1;
	int sum=0;//记录当前总价值
	while(1){
		while(sum<M){//头部尽可能向右延伸直到钱够
			right++;
			if(right==N)
				break;
			sum+=ivec[right];
		}
		if(sum<MIN){//比最省方案还便宜
			MIN=sum;
			result.clear();
			result.push_back(make_pair(left,right));
		}else if(sum==MIN)
			result.push_back(make_pair(left,right));

		while(sum>=M){//尾部收缩直到钱不够
			sum-=ivec[left];
			left++;
			if(sum>=M){//收缩过程中也要判断
				if(sum<MIN){
					MIN=sum;
					result.clear();
					result.push_back(make_pair(left,right));
				}else if(sum==MIN)
					result.push_back(make_pair(left,right));
			}
		}
		if(right==N-1)//头部到达终点,且尾部收缩到钱不够
			break;
	}
	for(auto it=result.begin();it!=result.end();it++)
		printf("%d-%d\n",(*it).first+1,(*it).second+1);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值