03-树2. Tree Traversals Again (25)及解题材料

03-树2. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

题意解析:入栈顺序即为先序遍历的顺序,出栈顺序即为中序遍历的顺序

解题思路:

    1.根据入栈出栈顺序,建立先序遍历数组与中序遍历数组。

    2.取先序序列中的第一个元素,该元素为根结点

    3.根据根结点在中序序列中查找根结点的位置,从而得到该树左子树结点个数(L)与右子树的结点个数(R)

    4.在后序序列数组中,第0到第L个元素为左子树,第L+1到第L+R个元素为右子树,最后一个元素为根结点

#include<iostream>
#include<string>
#include<iostream>
#include<stack>
using namespace std;
int pre[31],in[31],post[31];
stack<int>inputstack;
int solve(int prel,int inl,int postl,int n);
int main()
{
    int n,i,num1,num2;
    string str;
    while(cin>>n){
        num1=0;num2=0;
        
        for(i=0;i<2*n;i++){
            cin>>str;
            if(str=="Push"){
                cin>>pre[num1];
                inputstack.push(pre[num1]);
                num1++;
            }
            if(str=="Pop"){
                
                in[num2]=inputstack.top();
                num2++;
                inputstack.pop();
            }
        }
        solve(0,0,0,n);
    //    for(i=0;i<n;i++)
    //        cout<<pre[i]<<","<<in[i]<<endl;
        for(i=0;i<n;i++)
            if(i!=n-1)
                cout<<post[i]<<" ";
            else
                cout<<post[i]<<endl;
    }
    return 0;
}
int solve(int prel,int inl,int postl,int n){
    int root,i,l,r;
    if(n==0)return 0;
    root=pre[prel];
    post[postl+n-1]=root;
    if(n==1)return 0;
    for(i=0;i<n;i++){
        if(root==in[inl+i])
        {
        //    cout<<"i="<<i<<endl;
            break;
        }   
    }
    l=i;    
    r=n-1-l;
    solve(prel+1,inl,postl,l);
    solve(prel+1+l,inl+l+1,postl+l,r);
}


材料一:

https://i-blog.csdnimg.cn/blog_migrate/9db37dcf6a6a9485828bdb1d1735b290.png

先序输出:
A B D G H E C K F I J
中序输出:
G D H B E A K C I J F
后序输出:
G H D E B K J I F C A

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值