POJ 1308 Is It A Tree?

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
这是一道并查集的题目;

首先,一个init 函数 ;

然后是 一个找根节点的函数;

然后是一个合并函数,如果是一个结点指向自己,返回不是树

如果子节点已经有父节点,返回不是树

如果子节点没有父节点 ,那么子节点的父亲进行修改; 

然后就是在main函数里

进行了寻根操作,然后会有一个特殊情况,就是出现环,那么他也不是树;

#include <iostream>
#include <cstdio>

using namespace std;

int i ;
int s[1000] ;
int flag = 1 ; //flag  为0 不是树

void init( int * s)
{
    for ( i = 1 ; i < 1000 ; i ++ )
        s[i] = i ;
}

int find( int x , int *s )
{
    if ( s[x] == x )
        return x ;
    else
        return find(s[x] , s );
}

void setunion( int n , int m , int * s)
{
    if ( n == m )
        flag = 0 ;
    else if (s[m ] == m )
        s[m] = n ;
    else
        flag = 0 ;
}

int main()
{
    int n ,m ;
    int times = 1, first = 0 , root ;
    init(s) ;
    while ( scanf( "%d %d" , &n , &m) != EOF )
    {
        if ( n < 0 || m < 0 )
            break ;
        if (n == 0 && m == 0 )
        {
            for ( i = 0 ; i < 1000 ; i ++)
            {
                if ( first == 0 && s[i] != i) //找到第一个父节点不是本身的节点
                {
                    first = 1 ;
                    if (s [s[i] ] == i ) //存在环
                    {
                        flag  = 0 ;
                        break ;
                    }
                    root = find(i,s) ;//确定根节点
                }
                else if ( first == 1  &&s[i] != i)
                {
                    if ( root != find(i, s)  )
                        flag = 0 ;
                }
            }
            if ( flag == 1)
                printf("Case %d is a tree.\n",times);
            else
                printf("Case %d is not a tree.\n",times);
            times++ ;
            init(s);
            flag = 1 ;
            first =  0;
        }
        else
        {
            setunion(n,m,s);
        }
    }




    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值