PAT 1017. Queueing at Bank (25)

7 篇文章 0 订阅

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

提交代码


本题站队符合现实生活去银行的实际,容易理解模拟。


注意,若有多个空闲,不再选最小值,而是选第一个空闲



/*
	本题相当于每个窗口只有一个人站队,不再需要使用队列。
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAX=10010,INF=0x7fffffff;
int cnt,winTime[110],wait;//有效人数,每个窗口的当前最后时间
struct E{
	int arrive; //到达时间
	int process;  //需要服务的秒数,以秒为单位
}r[MAX];
bool cmp(E a,E b)
{
	return a.arrive<b.arrive;
}
int main()
{	
  	//freopen("G:\\in.txt","r",stdin);
	
	int i,s,n,k,hour,min,sec,service;//n人数,k窗口数
	while(scanf("%d%d",&n,&k)!=EOF){
		cnt=0; wait=0;
		for(i=0;i<n;i++){   //只保存有效到达时间
			scanf("%d%*c%d%*c%d %d",&hour,&min,&sec,&service);
//			printf("%d:%d:%d\n",hour,min,sec);
			if(3600*hour+min*60+sec<=17*3600){
				r[cnt].arrive=3600*hour+min*60+sec;
				r[cnt].process=service*60;
				cnt++;
			}
		}
		sort(r,r+cnt,cmp);
		for(i=0;i<k;i++)
			winTime[i]=8*3600;
		for(i=0;i<cnt;i++){  //注意此处是有效数据个数cnt!!!!!!!!!!
			int minTime=INF,id;
			for(s=0;s<k;s++){
				if(r[i].arrive>=winTime[s]){  //如果有空闲窗口,找到第一个空闲。
					winTime[s]=r[i].arrive+r[i].process;
					id=-1;  //做标志
					break;
				}
				else{
					if(winTime[s]<minTime){
						minTime=winTime[s];
						id=s;
					}
				}
			}
			if(id!=-1){
				wait=wait+winTime[id]-r[i].arrive;
//				printf("***%f***\n",(double)wait/60);
				winTime[id]=winTime[id]+r[i].process;
			}
		}
		printf("%.1f\n",(double)wait/(cnt*60));  //秒化为分钟
		
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值