hdu-绝对值排序

http://acm.hdu.edu.cn/showproblem.php?pid=2020

Problem Description
输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
 

Input
输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
 

Sample Input
  
  
3 3 -4 2 4 0 1 2 -3 0
 

Sample Output
  
  
-4 3 2 -3 2 1 0
 

#include<iostream>
#include <algorithm>
#include<cmath>
using namespace std;
bool cmp(int x,int y)
{
    return x>y;
}
int main()
{
    int n;
    int b[200];
    int a[200];
    while(cin>>n)
    {
        if(n==0)
        return 0;
        for(int i=0; i<n; i++)
        {
            cin>>a[i];
            b[i]=abs(a[i]);
        }
        sort(b,b+n,cmp);
        int m=0;
        for(int m=0;m<n;m++)
        {
            for(int i=0;i<n;i++)
            {
                if(abs(b[m])==abs(a[i]))
                    b[m]=a[i];
            }
        }
         for(int i=0; i<n; i++)
        {
            if(i==0)
            cout<<b[i];
            else
            cout<<" "<<b[i];
        }
        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值