hdu-第几天

http://acm.hdu.edu.cn/showproblem.php?pid=2005


Problem Description
给定一个日期,输出这个日期是该年的第几天。
 

Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。
 

Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
 

Sample Input
  
  
1985/1/20 2006/3/12
 

Sample Output
  
  
20 71
 

分析:


#include <iostream>
using namespace std;
int main()
{
    int year,month,day;

    int a[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    char ch;
    while(cin>>year>>ch>>month>>ch>>day)
    {
    for(int i=1;i<month;i++)
        day+=a[i];


    if((year%4==0 &&year%100!=0)||year%400==0&&month>2)
         day+=1;
       cout<<day<<endl;
    }
     return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值