hdu2126Buy the souvenirs (01背包+记录路径的种数)

Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”

Sample Input
  
  
2 4 7 1 2 3 4 4 0 1 2 3 4

Sample Output
  
  
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.
题意:求出买得记念品个数最多,并这些个数可以用几个方式去买。
#include<stdio.h>
int dp[2][5005],m,k,s;
void zeroonepack(int use)
{
   for(int v=m;v>=use;v--)
   if(dp[0][v]<dp[0][v-use]+1)
   {
       dp[0][v]=dp[0][v-use]+1;
       dp[1][v]=dp[1][v-use];//同一价值dp[0][v-use]可以是多种组成,当价值dp[0][v]更时,组成的种数必然和它的前驱一样多
   }
   else if(dp[0][v]==dp[0][v-use]+1)//价值相同,那么加上前驱的种数
   dp[1][v]+=dp[1][v-use];
}
int main()
{
    int t,n,a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++) dp[0][i]=0,dp[1][i]=1;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);zeroonepack(a);
        }
        s=dp[0][m]; k=dp[1][m];
        if(s==0)printf("Sorry, you can't buy anything.\n");
        else
        {
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",k,s);
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值