poj 1679 The Unique MST (次小生成树)

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
1. V’ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题意

t(t <= 20)组数据,每组数据给出n,m(n <= 100),表示有n个点,m条边。每条边给出x,y,w表示x到y有一条权值为w的边。问最小生成树是否只有唯一解。

题解

判断最小生成树是否唯一的方法很简单:看次小生成树的值是否与它相等~所以跑一个很朴素的复杂度挺高的次小生成树即可。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 1010;

struct Node {
    int u, v, w, next;
} e[N], b[N];
int t, n, m, num, ans, sum, tot, fa[N], head[N], dis[N][N];

bool cmp(const Node &a, const Node &b) {
    return a.w < b.w;
}

void add(int u, int v, int w) {
    num ++;
    e[num].v = v;
    e[num].w = w;
    e[num].next = head[u];
    head[u] = num;
}

int find(int x) {
    if(x == fa[x]) return x;
    return fa[x] = find(fa[x]);
}

void kruskal() {
    sort(b + 1, b + m + 1, cmp);
    for(int i = 1; i <= m; i ++) {
        int fx = find(b[i].u), fy = find(b[i].v);
        if(fx == fy) continue;
        fa[fy] = fx; sum += b[i].w; b[i].next = true;
        add(b[i].u, b[i].v, b[i].w); add(b[i].v, b[i].u, b[i].w);
        if(tot ++ == n - 1) return;
    }
}

void dfs(int now, int u, int f, int maxs) {
    dis[now][u] = maxs;
    for(int i = head[u]; i; i = e[i].next) {
        int v = e[i].v;
        if (v != f) dfs(now, v, u, max(maxs, e[i].w));
    }
}

int main() {
    scanf("%d", &t);
    while(t --) {
        sum = num = tot = 0;
        memset(b, 0, sizeof(b));
        memset(head, 0, sizeof(head));
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= n; i ++) fa[i] = i;
        for(int i = 1; i <= m; i ++)
            scanf("%d %d %d", &b[i].u, &b[i].v, &b[i].w);
        kruskal(); ans = 0x3ffffff;
        for(int i = 1; i <= n; i ++) dfs(i, i, 0, 0);
        for(int i = 1; i <= m; i ++)
            if(! b[i].next) ans = min(ans, sum + b[i].w - dis[b[i].u][b[i].v]);
        if(ans != sum) printf("%d\n", sum);
        else printf("Not Unique!\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值