poj 1208 The Blocks Problem (链表模拟)

本文介绍了计算机科学中一个简单的抽象研究领域——Block World问题,涉及链表模拟。通过一系列特定的机器人手臂操作指令,如move、pile等,来处理堆叠在平面上的方块。你需要解析并执行这些指令,直到遇到'quit'命令。输入包含块的数量和一系列操作,输出是最终的方块状态。示例输入和输出展示了如何处理命令和输出最终布局。文章探讨了如何使用链表实现解决方案,强调了链表在处理这类问题时的优势。
摘要由CSDN通过智能技术生成

Description

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands.
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0 <= i < n-1 as shown in the diagram below:

The valid commands for the robot arm that manipulates blocks are:

move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

The output should consist of the final state of the blocks world. Each original block position numbered i ( 0 <= i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don’t put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

题意

题目是很长的,大概的(从网上扒来的)意思是给定一个长度n,有0~n-1编号的箱子和位置,起始个编号的箱子放在相同编号的位置。
有一系列操作:

  move a onto b,将a,b上面的箱子放回初始位置,并将a放到b箱上。

  move a over b ,将a上面的箱子放回初始位置,并将a放到b箱最上方。

  pile a onto b ,将b上面的箱子放回初始位置,并将a和a上的箱子一起放到b箱上。

  pile a over b,将a和a上的箱子一起放到b箱最上方。

  要求输出最后每个位置的箱子。输出要求很严格,一个多余的空格都不能有。

题解

其实我就是想学链表虐自己来着,如果想看正解的就可以直接使用数组做。链表方法较数组更难理解,但速度会快一点。

代码

#include <algorithm>
#include <cstdio>
#include <string>
#include <iostream>
using namespace std;

struct Node {
    int data;
    Node* from;
    Node* next;
} block[30];

void clear(Node *tmp) {
    Node *last = tmp;
    while(tmp->next != NULL) {
        tmp = tmp->next;
        last->next = NULL;
        tmp->from = NULL;
        last = tmp;
    }
}

bool check(Node *a, Node *b) {
    Node *tmp = a;
    while(tmp != NULL)
        if(tmp->data == b->data)
            return true;
        else tmp = tmp->next;
    tmp = a;
    while(tmp != NULL)
        if(tmp->data == b->data)
            return true;
        else tmp = tmp->from;
    return false;
}

int main() {
    int a, b, n;
    string s1, s2;
    scanf("%d", &n);
    for(int i = 0; i < n; i ++) {
        block[i].data = i;
        block[i].from = NULL;
        block[i].next = NULL;
    }
    while(cin >> s1 && s1 != "quit" && cin >> a >> s2 >> b)
        if(! check(&block[a], &block[b])) {
            Node *tmp = block[a].from;
            if(tmp != NULL)
                tmp->next = NULL;
            if(s1 == "move") {
                if(s2 == "onto") {
                    clear(&block[a]);
                    clear(&block[b]);
                    block[a].from = &block[b];
                    block[b].next = &block[a];
                }
                else {
                    clear(&block[a]);
                    Node *tmp = &block[b];
                    while(tmp->next != NULL)
                        tmp = tmp->next;
                    block[a].from = tmp;
                    tmp->next = &block[a];
                }
            }
            else {
                if(s2 == "onto") {
                    clear(&block[b]);
                    block[a].from = &block[b];
                    block[b].next = &block[a];
                }
                else {
                    Node *tmp = &block[b];
                    while(tmp->next != NULL)
                        tmp = tmp->next;
                    tmp->next = &block[a];
                    block[a].from = &block[b];
                }
            }
        }
    for(int i = 0; i < n; i ++) {
        printf("%d:", i);
        if(block[i].from == NULL) { 
            Node *tmp = &block[i];
            while(tmp != NULL) {
                printf(" %d", tmp->data);
                tmp = tmp->next;
            }
        }
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值