hdu 3371 Connect the Cities

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
 


题解:

       依然是并查集+Kruskal算法,很简单的水题,不过竟然WA了一次,因为数组开小了,要开到25000以上,后来一次是TLE,为什么呢?用G++提交超时了,换成C++提交,过了.......   G++怎么这么慢.......     TAT

 

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int root[10000];
struct node
{
    int x,y,fit;

} s[25555];
bool cmp(node a,node b)
{
    return a.fit<b.fit;
}
int look(int n)
{
    if(n!=root[n])
        root[n]=look(root[n]);
    return root[n];
}
void _union(int a,int b)
{
    a=look(a);
    b=look(b);
    if(a!=b) root[a]=b;
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        int i;
        for(i=0; i<=a; i++) root[i]=i;
        for(i=0; i<b; i++)
            scanf("%d%d%d",&s[i].x,&s[i].y,&s[i].fit);
        sort(s,s+b,cmp);
        for(i=0; i<c; i++)
        {
            int aa,j,bb,cc;
            scanf("%d %d",&aa,&bb);
            for(j=1; j<aa; j++)
            {
                scanf("%d",&cc);
                _union(bb,cc);
            }
        }
        int sum=0,ans=0;
        for(i=0; i<b; i++)
            if(look(s[i].x)!=look(s[i].y))
            {
                _union(s[i].x,s[i].y);
                sum+=s[i].fit;
            }

        for(i=1; i<=a; i++)
            if(i==look(i))  ans++;
        if(ans==1)  printf("%d\n",sum);
        else printf("-1\n");

    }

    return 0;
}


 

   

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值