hdu 1829 A Bug's Life

Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.  

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 


题解:

      并查集的题,开两个数组,root用来记 父节点,sex用来记住  发生关系的异性,当两个人的  sex[]为空时,即sex[x]=y;sex[y]=x;  当存在不为空(比如sex[x]存在)的时候,就将sex[x]与y 并在一起, 每输入一次判断一次是否两个人在一个集合里面,如果在一个集合里面,就说明两个人是同性恋。(切记:测试数据的数目输入时不能使用while(scanf("%d",&n)!=EOF)的形式)。

 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int root[2010],sex[2010];
int look(int n)
{
    if(n!=root[n])
        root[n]=look(root[n]);
    return root[n];
}
void _union(int a,int b)
{
    a=look(a);
    b=look(b);
    if(a!=b) root[a]=b;
}
int main()
{
    int n;
      scanf("%d",&n);                   //千万不能写while(scanf("%d",&n)!=EOF);  因此错了好几次呢  凌乱了 TAT

        int t=1;

        while(t<=n)
        {
            int mm,nn,i,x,y,flu=0;
            scanf("%d%d",&mm,&nn);
            for(i=0;i<=mm;i++) root[i]=i;
            memset(sex,0,sizeof(sex));

            for(i=0;i<nn;i++)
            {
                scanf("%d%d",&x,&y);

                if(look(x)==look(y))  flu=1;
                else if(!sex[x]&&!sex[y])  {sex[x]=y;sex[y]=x;}
                else if(!sex[x])  {sex[x]=y;_union(x,sex[y]);}
                else if(!sex[y])  {sex[y]=x;_union(sex[x],y);}
                else {_union(sex[x],y);_union(x,sex[y]);}

            }
            if(flu)  printf("Scenario #%d:\nSuspicious bugs found!\n\n",t++);
            else printf("Scenario #%d:\nNo suspicious bugs found!\n\n",t++);

        }


    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值