线段树||树状数组poj2464

Language:
Brownie Points II
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1939 Accepted: 682

Description

Stan and Ollie play the game of Odd Brownie Points. Some brownie points are located in the plane, at integer coordinates. Stan plays first and places a vertical line in the plane. The line must go through a brownie point and may cross many (with the same x-coordinate). Then Ollie places a horizontal line that must cross a brownie point already crossed by the vertical line.  
Those lines divide the plane into four quadrants. The quadrant containing points with arbitrarily large positive coordinates is the top-right quadrant.  

The players score according to the number of brownie points in the quadrants. If a brownie point is crossed by a line, it doesn't count. Stan gets a point for each (uncrossed) brownie point in the top-right and bottom-left quadrants. Ollie gets a point for each (uncrossed) brownie point in the top-left and bottom-right quadrants.  

Stan and Ollie each try to maximize his own score. When Stan plays, he considers the responses, and chooses a line which maximizes his smallest-possible score.

Input

Input contains a number of test cases. The data of each test case appear on a sequence of input lines. The first line of each test case contains a positive odd integer 1 < n < 200000 which is the number of brownie points. Each of the following n lines contains two integers, the horizontal (x) and vertical (y) coordinates of a brownie point. No two brownie points occupy the same place. The input ends with a line containing 0 (instead of the n of a test).

Output

For each input test, print a line of output in the format shown below. The first number is the largest score which Stan can assure for himself. The remaining numbers are the possible (high) scores of Ollie, in increasing order.

Sample Input

11
3 2
3 3
3 4
3 6
2 -2
1 -3
0 0
-3 -3
-3 -2
-3 -4
3 -7
0

Sample Output

Stan: 7; Ollie: 2 3;

题意:在平面直角坐标系中给你N个点,stan和ollie玩一个游戏,首先stan在竖直方向上画一条直线,该直线必须要过其中的某个点,然后ollie在水平方向上画一条直线,该直线的要求是要经过一个stan之前画过的点。 这时候平面就被分割成了四块,两个人这时候会有一个得分,stan的得分是平面上第1、3象限内的点的个数,ollie的得分是平面上第2、4象限内的点的个数,在统计的时候在所画线上的点都不计算在内。求最终stan使得自己的最差得分最高,并且输出此时ollie的得分。

思路:需要两个树状数组,分别维护左右两边。对y坐标进行离散化,然后按x进行排序,预先把所有的点加到右边的树状数组中,然后扫一遍,不断更新左右的树状数组和答案

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=200010;
int N;
int l[maxn],r[maxn];
int Y[maxn];
struct P
{
    int x,y;
    bool operator<(const P & a)const
    {
        return x<a.x;
    }
}p[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void update(int *s,int x,int val)
{
    while(x<=N)
    {
        s[x]+=val;
        x+=lowbit(x);
    }
}
int sum(int *s,int x)
{
    int ans=0;
    while(x>0)
    {
        ans+=s[x];
        x-=lowbit(x);
    }
    return ans;
}
int main()
{
    while(scanf("%d",&N)!=EOF,N)
    {
        for(int i=1;i<=N;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            Y[i]=p[i].y;
        }
        sort(p+1,p+1+N);
        sort(Y+1,Y+1+N);
        int cnt=unique(Y+1,Y+N+1)-Y-1;
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        for(int i=1;i<=N;i++)
            update(r,lower_bound(Y+1,Y+cnt+1,p[i].y)-Y,1);
        int st=1,Stan=-1;
        vector<int> Ollie;
        for(int i=2;i<=N+1;i++)
        {
            if(i==N+1||p[i-1].x!=p[i].x)
            {
                for(int j=st;j<i;j++)
                    update(r,lower_bound(Y+1,Y+cnt+1,p[j].y)-Y,-1);
                int stan=-1,ollie=-1;
                for(int j=st;j<i;j++)
                {
                    int pos=lower_bound(Y+1,Y+cnt+1,p[j].y)-Y;
                    int a=sum(r,cnt)-sum(r,pos)+sum(l,pos-1);
                    int b=sum(l,cnt)-sum(l,pos)+sum(r,pos-1);
                    if(b==ollie)stan=min(stan,a);
                    else if(b>ollie)stan=a,ollie=b;
                }
                if(stan>Stan)
                {
                    Stan=stan;
                    Ollie.clear();
                }
                if(stan==Stan)Ollie.push_back(ollie);
                for(int j=st;j<i;j++)
                    update(l,lower_bound(Y+1,Y+cnt+1,p[j].y)-Y,1);
                st=i;
            }
        }
        printf("Stan: %d; Ollie:",Stan);
        sort(Ollie.begin(),Ollie.end());
        cnt=unique(Ollie.begin(),Ollie.end())-Ollie.begin();//cout<<cnt;
        for(int j=0;j<cnt;j++)printf(" %d",Ollie[j]);
        printf(";\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!
提供的源码资源涵盖了python应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值