NYOJ--8--一种排序

一种排序

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);

1.按照编号从小到大排序

2.对于编号相等的长方形,按照长方形的长排序;

3.如果编号和长都相同,按照长方形的宽排序;

4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
输入
第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,

第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
样例输出
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1
import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;


public class NY_8 {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		int n=input.nextInt();
		int a,b,c;
		while(n-->0){
			int m=input.nextInt();
			Rt [] arr=new Rt [m];
			for(int i=0; i<m; i++){
				Rt r=new Rt();
				r.no=input.nextInt();
				a = input.nextInt();
				b = input.nextInt();
				r.length=Math.max(a, b);
				r.width=a+b-r.length;
				arr[i]=r;
			}
			Arrays.sort(arr, new RtCom());
			System.out.println(arr[0].no+" "+arr[0].length+" "+arr[0].width);
			a=arr[0].no;
			b=arr[0].length;
			c=arr[0].width;
			for(int i=1; i<arr.length; i++){
				if(a==arr[i].no && b==arr[i].length && c==arr[i].width){
					continue;
				}else{
					System.out.println(arr[i].no+" "+arr[i].length+" "+arr[i].width);
					a=arr[i].no;
					b=arr[i].length;
					c=arr[i].width;
				}
			}
			
		}
	}
}
class RtCom implements Comparator{
	
	public int compare(Rt r1,Rt r2){
		if(r1.no != r2.no){
			return r1.no>r2.no?1:-1;
		}
		else if(r1.length != r2.length &&r1.no == r2.no){
			return r1.length>r2.length?1:-1;
		}
		else{
			return r1.width>r2.width?1:-1;
		}
	}
	@Override
	public int compare(Object o1, Object o2) {
		// TODO Auto-generated method stub
		return 0;
	}
}
class Rt{
	int no,length,width;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值