acm_18The Triangle

The Triangle

时间限制: 1000 ms   内存限制: 65535 KB
难度: 4
描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
样例输出
30
上传者
苗栋栋

import java.util.Scanner;

public class Triangle{

    public static void main(String[] args) {
          Triangle triangle = new Triangle();
          triangle.solution();
    }
    int[] numlist;
    int[] resultList;
    int rows;
    public void solution() {
        getData();
        System.out.println(handle());
    }
   
    //获取输入;
    private void getData(){
        Scanner in = new Scanner(System.in);
        rows = in.nextInt();
        //计算三角形中一共有多少个元素
        int temp = (1+rows)*rows/2;
        numlist = new int[temp];
        resultList = new int[temp];
       
        for(int i = 0 ; i < numlist.length; i++){
            numlist[i] = in.nextInt();
        }
    }
   
    //处理数据
    private int handle(){
        for(int i = 1; i <=rows ;i++){
            for(int j = 1; j<=i ; j++){
                if(i == 1){
                    setResultList(1, 1, acessTriangle(1, 1, false));
                    continue;
                }
               
                if(j == 1){
                    setResultList(i, j, acessTriangle(i-1, j, true)+acessTriangle(i, j, false));
                    continue;
                }
               
                if(j > i-1){
                    setResultList(i, j, acessTriangle(i-1, j-1, true)+acessTriangle(i, j, false));
                }else{
                    int temp = Math.max(acessTriangle(i-1, j-1, true), acessTriangle(i-1, j, true));
                    setResultList(i, j, temp+acessTriangle(i, j, false));
                }
            }
        }
        int result = -1;
        for(int  j=  1; j<=rows ;j++){
            result = (result
        }
        return result;
    }
   
    private void setResultList(int x,int y,int value){
        int temp = (1+x-1)*(x-1)/2;
        resultList[temp+y-1]= value;
    }
   
    //以三角形的形式访问数组
    private int acessTriangle(int x ,int y,boolean isresult){
        //获取该排之前有多少个元素
        int temp = (1+x-1)*(x-1)/2;
        if(isresult){
            return resultList[temp+y-1];
        }else{
            return numlist[temp+y-1];
        }
    }
}


思想上属于遍历


以上算法存在空间和时间上的冗余,   改进方案是 只开辟2个长度为三角高度的数组,一个数组存上一行对应点的最大路径,一个数组存当前输入节点的最大路劲, 然后交替使用    输入结束即可获得结果

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值