欢迎前往个人博客 驽马点滴 和视频空间 哔哩哔哩-《挨踢日志》
Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
【说明】简单的题目,适合练手
#include<iostream>
using namespace std;
int main()
{
int triangle[5050];
int row;
cin >> row;
for (int i = 1; i <= row; ++i)
{
for (int j = 1; j <= i; ++j)
{
cin >> triangle[(i-1)*i/2+j-1];
}
}
for (int k = row-1; k > 0; --k)
{
for (int j = 1; j <= k; ++j)
{
triangle[(k-1)*k/2+j-1] += (triangle[k*(k+1)/2+j-1] > triangle[k*(k+1)/2+j]) ? triangle[k*(k+1)/2+j-1] : triangle[k*(k+1)/2+j];
}
}
cout << triangle[0] << endl;
return 0;
}
欢迎前往个人博客 驽马点滴 和视频空间 哔哩哔哩-《挨踢日志》