POJ 1844 Sum

http://poj.org/problem?id=1844

Sum
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9716 Accepted: 6350

Description

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N. 

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem. 

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

Hint

The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.

Source


#include"stdio.h"
#include"math.h"
int main()
{
	int S,N;
	while(scanf("%d",&S)!=EOF)
	{
		N=(int)sqrt(2.0*S);
		if(N*(1+N)<2*S)
			N++;
		if( (S-(N+1)*N/2) %2 == 0)
			printf("%d\n",N);
		else
		{
			if(N%2)
				printf("%d\n",N+2);
			else
				printf("%d\n",N+1);
		}
	}
	return 0;
}

1844Accepted176K0MSC++305B2013-07-14 13:38:41

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值