uva 846 Steps(数学规律)

942 篇文章 2 订阅

 Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers:  0$ \le$x$ \le$y < 231 . For each test case, print a line giving the minimum number of steps to get from  x  to  y .

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4
题目大意:给出两个数字, 要求从a走到b, 第一步和最后一步只能走1, 每步的值可以是前面一步值-1, 不变和+1.求a到b最少走几步。

解题思路:1...k k ...1所需步为2 * k,

<1>2 * sum(1~k)  ->2 * k

<2>2 * sum(1~k)  ~2 *  sum(1~k) + 1 + k  -> 2 *k + 1

<3>2 * sum(1~k) + k + 1 ~2 * sum(1~k+1)  -> 2 *(k + 1)

#include<stdio.h>

int main(){
	long long a, b, t, n, sum, k;
	scanf("%lld", &t);
	while (t--){
		scanf("%lld%lld", &a, &b);
		n = b - a;
		sum =  0;
		if (n == 0){
			printf("%lld\n", n);
			continue;}

		for (long long i = 0; ; i++){
			sum += 2 * i;
			k = sum - n;
			if (k >= 0 && k < i){
				printf("%lld\n", 2 * i);
				break;
			}
			else if(k >= i){
				printf("%lld\n", 2 * i - 1);
				break;
			}
		}
	}
	return 0;}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值