hdu4433 locker 密码锁(枚举)

locker

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 883    Accepted Submission(s): 374


Problem Description
A password locker with N digits, each digit can be rotated to 0-9 circularly.
You can rotate 1-3 consecutive digits up or down in one step.
For examples:
567890 -> 567901 (by rotating the last 3 digits up)
000000 -> 000900 (by rotating the 4th digit down)
Given the current state and the secret password, what is the minimum amount of steps you have to rotate the locker in order to get from current state to the secret password?
 

Input
Multiple (less than 50) cases, process to EOF.
For each case, two strings with equal length (≤ 1000) consists of only digits are given, representing the current state and the secret password, respectively.
 

Output
For each case, output one integer, the minimum amount of steps from the current state to the secret password.
 

Sample Input
  
  
111111 222222 896521 183995
 

Sample Output
  
  
2 12
 

Source
 

dp[i][j][k]表示 前i个已经完全匹配,而这时候,第i+1个已经加了j位,第i+2位已经加了k

转移分为两步,枚举加,枚举减

注意如果第i位加了a,第i+1位加了b,第i+2位加了c,那么a>=b>=c这个关系不能错

#include<stdio.h>
#include<string.h>
#define inf 1000000000;
int dp[1005][10][10];

int min(int x,int y)
{
	return x<y?x:y;
}
int main()
{
	int i,j,k,l,a,c,b,len;
	char s1[1005],s2[1005];
	while(scanf("%s%s",s1,s2)!=EOF)
	{
		len=strlen(s1);
		for(i=0;i<=len;i++)
			for(j=0;j<10;j++)
				for(k=0;k<10;k++)
					dp[i][j][k]=inf;
		dp[0][0][0]=0;
		for(i=0;i<len;i++)
			for(j=0;j<10;j++)
				for(k=0;k<10;k++)
				{
					c=(20+s2[i]-s1[i]-j)%10;//向上
					for(a=0;a<=c;a++)
						for(b=0;b<=a;b++)
						{
							dp[i+1][(k+a)%10][b]=min(dp[i+1][(k+a)%10][b],dp[i][j][k]+c);//最多需要c步。
							//当前状态的k到了i+1状态时到了对应的j位置
						}
					c=(10-c)%10;//向下
					for(a=0;a<=c;a++)
						for(b=0;b<=a;b++)
						{
							dp[i+1][(k-a+10)%10][(10-b)%10]=min(dp[i+1][(k-a+10)%10][(10-b)%10],dp[i][j][k]+c);
						}
				}
				printf("%d\n",dp[len][0][0]);

	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值