Hurry Up

Problem Description

GG is some what afraid of his MM. Once his MM asks, he will always try his best to rush to their home.
Obvious, he can run home in straight line directly. Alternatively, he can run to the main road and call the taxi.
You can assume there is only one main road on the x-axis, with unlimited length.
Given the initial location of GG and his destination, please help to ask the minimize time to get home.
GG will always run at the fixed speed of vr, and the taxi can move at the fixed speed of vt
You can also assume that, only GG reach the main road, he can catch the taxi immediately. And the taxi will go towards home ( not necessay along the road ).
Bisides, GG can run arbitrary length, and pay arbitrarily for the taxi.

Input

Multiple test cases. First line, an integer T ( 1 ≤ T ≤ 2000 ), indicating the number of test cases.
For each test cases, there are 6 integers x1, y1, x2, y2, vr, vt in a line.
( -1000 <= x1, y1, x2, y2 <= 1000, 1 <= vr < vt <= 1000 )
(x1, y1) : the initial location of GG
(x2, y2) : the destination location of GG
vr: GG's run speed
vt: taxi's speed

Output

For each test case, output a real number with 2 digits after the arithmetic point. It is the shorest time for GG to reach home.

Sample Input

2
1 1 2 2 1 2
1 1 2 2 1 7

Sample Output

1.41
1.32

#include <iostream>
#include <iomanip>
#include <cmath>

using namespace std;

int n, x1, y, x2, y2, vr, vt;

double cal(double x)   // 注意注意
{
    return sqrt(pow(x - x1, 2) + pow(y, 2)) / vr + sqrt(pow(x2 - x, 2) + pow(y2, 2)) / vt;
}

int divide(int x1, int x2)
{
    double left, right, left2, right2;
    left = x1;             right = x2;
    //二分三分
    while (fabs(left - right) > 1e-7)   //fabs函数是用于小数的绝对值,abs是整形
    {
        left2 = (left*2 + right) / 3;
        right2 = (right*2 + left) / 3;
        if (cal(left2) > cal(right2))             left = left2;
        else                                      right = right2;
    }
    return left;
}
int main ( )
{
    double t1, t2, x;
    cin >> n;
    while (n--)
    {
        cin >> x1 >> y >> x2 >> y2 >> vr >> vt;

        t1 = t2 = 0.0;
        t1 = sqrt(pow(x2 - x1, 2) + pow(y2 - y, 2)) / vr;

        if( x1 > x2)    { int a = x1; x1 = x2; x2 = a; }    //x1和x2的大小判断且转换值
        x = divide(x1, x2);

        t2 = sqrt(pow(x - x1, 2) + pow(y, 2)) / vr + sqrt(pow(x2 - x, 2) + pow(y2, 2)) / vt;
        //输出判断
        if (t1 < t2)
            cout << setiosflags(ios::fixed) << setprecision(2) << t1 << endl;
        else
            cout << setiosflags(ios::fixed) << setprecision(2) << t2 << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值