UVA 340 Master-Mind Hints

题目链接:UVA 340 Master-Mind Hints

 Master-Mind Hints 

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 , such that tex2html_wrap_inline45 . Match (i,j) is called strong when i = j, and is called weakotherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independentwhen all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)

题意


Master-Mind是一种2个人的游戏。 其实就是学生常玩的几A几B的游戏(规则或许有些许不同)。 其中一个人担任出题者,他选一串1到9数字 当作密码(可以重复)。 另一个人为解题者,他要去猜密码为何。 解题者每次猜测后,出题者以某种格式回答他这次猜的结果。 在游戏开始之前,双方先协议密码的长度,假设是n。 在出题者设定密码(s1,s2,...sn) 后,由解题者来猜(g1,g2,...gn)。 如 果同样位置gi=si, 那解题者得到一个A。 如果gi=sj,但i不等于j,那解题者得到一个B。 请注意:不管是得A或得B,每个 gi最多只能对应到一个sj,而且得A比得B优先。 举例说明:密码为1 2 3 4,若猜题者猜1 1 5 6,那出题者应该回答1A0B,而不是0A1B。 如果某个猜测得到 nA0B,那就代表猜题者完全猜中密码了。

分析


开两个标记数组,一个用以标记数字相同且位置相同的个数,一个用以标记数字相同但位置不同的个数,注意从左到右,如果匹配过了则不能与下一个进行重复匹配。然后循环,找答案标记。

代码


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int n, s[1010], g[1010], cas = 1;
    bool viss[1010], vist[1010];
    while(scanf("%d", &n), n)
    {
        for(int i = 0; i < n; i++)
            scanf("%d", &s[i]);
        printf("Game %d:\n", cas++);
        while(1)
        {
            int cnt = 0;
            for(int i = 0; i < n; i++)
            {
                scanf("%d", &g[i]);
                if(g[i]==0) cnt++;
            }
            if(cnt == n) break;
            int ca = 0, cb = 0;
            memset(viss, false, sizeof(viss));
            memset(vist, false, sizeof(vist));
            for(int i = 0; i < n; i++)
                if(s[i]==g[i])
                {
                    ca++;
                    viss[i] = vist[i] = true;
                }
            for(int i = 0; i < n; i++)
            {
                for(int j = 0; j < n; j++)
                {
                    if(!viss[i] && !vist[j] && s[i]==g[j])
                    {
                        cb++;
                        viss[i] = vist[j] = true;
                    }
                }
            }
            printf("    (%d,%d)\n", ca, cb);
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值