TOJ 4365 ZOJ 3623 Battle Ships / 完全背包

Battle Ships

时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte

描述

Battle Ships is a new game which is similar toStar Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takesti seconds to produce the i-th battle ship and this battle ship can make the tower lossli longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

输入

There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) andL(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships,L is the longevity of the Defense Tower. Then the following N lines, each line contains two integerst i(1 ≤ t i ≤ 20) and li(1 ≤li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

输出

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

样例输入

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

样例输出

2
4
5

http://blog.csdn.net/ten_three/article/details/14487499

#include <stdio.h>
#include <string.h>
struct node
{
	int t;
	int l;
}a[40];
int dp[340];
int max(int x,int y)
{
	return x > y ? x : y;
}
int main()
{
	int n,l,i,j;
	while(scanf("%d %d",&n,&l)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(i = 1;i <= n; i++)
		{
			scanf("%d %d",&a[i].t,&a[i].l);
		}
		for(i = 1;i <= n; i++)
		{
			for(j = 1; j <= 330; j++)
			{
				dp[j + a[i].t] = max(dp[j+a[i].t],dp[j] + j * a[i].l);
			}
		}
		for(i = 1; i <= 330; i++)
			if(dp[i] >= l)
				break;
		printf("%d\n",i);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值