ZOJ-1004(AOJ-466) Anagrams by Stack

37 篇文章 0 订阅
26 篇文章 0 订阅
Anagrams by Stack
Time Limit: 1000 ms   Case Time Limit: 1000 ms   Memory Limit: 64 MB
Description
How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input
The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output
For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Process
A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input
OriginalTransformed
madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output
OriginalTransformed
[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]

Source
Zhejiang University Local Contest 2001

————————————————————中二的分割线————————————————————
思路:这道题,看得出来是想要考察栈(读懂之后整个人都哭了)。然而需要注意的是,要输出所有的可行解。这就牵扯到决策了。每当这一步可以走的时候,我要考虑走它和不走它这两种情况。没错!聪明的你想到了,先走这一步dfs进去,之后退回来这一步再dfs进去。这样所有的解都可以遍历到。要想悔棋,就要借助新变量“存一下档”。
代码如下:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
char sta[50], ans[20], str[2][20];
int id, top, len;
void dfs(int k1, int k2){
    if(k2 == len){//每当匹配到最后一个目标字母的时候,ans[]当中就保存了一个可行解
        int i;
        for(i = 0; i < id; i++)
            printf("%c ", ans[i]);
        printf("\n");
    }
    if(k1 < len){//当前字母还没有到最后一个的时候,进栈
        sta[++top] = str[0][k1];
        ans[id++] = 'i';//作进栈记录
        dfs(k1+1, k2);//dfs进栈之后的当前下一个字母
        top--;  id--;//本层dfs完成之后,可行解已经打印,出栈,消除ans[]中这一步。在此之前,还需要完成下面的dfs
    }
    if (top != -1 && sta[top] == str[1][k2]){//栈不为空,而且栈首可以匹配目标字母
        char temp = sta[top--];//先存档,然后出栈
        ans[id++] = 'o';//作出栈记录
        dfs(k1, k2+1);//栈首出栈后,dfs下一个目标字母
        sta[++top] = temp;//读档,即假设这一步出栈并没做
        id--;//消除ans[]中这一步
    }
}
int main(){
    int len2;
    while(~scanf("%s%s", str[0], str[1])){
        top = -1;
        len = strlen(str[0]);
        len2= strlen(str[1]);
        if(len != len2)  puts("[\n]");//长度不匹配肯定无解
        else{
            puts("[");
            id = 0;
            dfs(0, 0);
            puts("]");
        }
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值