poj 2352 一维树状数组

13 篇文章 0 订阅
12 篇文章 0 订阅

题目来源Ural Collegiate Programming Contest 1999 poj上的链接点这儿(这个是难得的1Y"o((>ω< ))o" 


下面放出题目 

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 29948   Accepted: 13088

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目就是给出了好多点的二维平面坐标,然后用level来表示横纵坐标都不大于这个点坐标的点的个数。比如样例中(1,1)的level是0,(5,5)的level是3。然后要依次输出leve=0, 1, 2 ……, n - 1的点的个数,样例中level = 0的点有一个, = 1的有两个,=2 和 3的各有一个,所以输出时1 2 1 1 0.

我们可以将点按照坐标序(先比较横坐标,横坐标相等时比较纵坐标)排一遍,这时,对每个点,我们只需统计已经出现过的点中,纵坐标不大于它纵坐标的点的个数。我们用sum[i]来记录已经出现过的纵坐标为i的点的个数。但是由于数据量较大,如果每次都要累加的话,肯定会TLE,所以我们需要一个数据结构来快速求和,很明显,树状数组便符合这个要求(复杂点的线段树当然也可以)(因为是树状数组,所以sum[]数组就改成了bintree[]数组)。

而且,由于初始给出的数据是按照纵坐标递增的顺序给出的,我们可以再开始便对纵坐标进行离散化处理,这样就避免了纵坐标数据范围的问题。


下面放出代码。

#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)>(b)?(b):(a))
#define rep(i,initial_n,end_n) for(int (i)=(initial_n);(i)<(end_n);i++)
#define repp(i,initial_n,end_n) for(int (i)=(initial_n);(i)<=(end_n);(i)++)
#define reep(i,initial_n,end_n) for((i)=(initial_n);(i)<(end_n);i++)
#define reepp(i,initial_n,end_n) for((i)=(initial_n);(i)<=(end_n);(i)++)
#define eps 1.0e-9
#define MAX_N

using namespace std;
typedef pair<int, int> pii;
typedef pair<double, double> pdd;
typedef __int64 ll;
typedef unsigned __int64 ull;

int bintree[15010], level[15010];

struct node {
    int x, y;
    friend bool operator < (node a, node b) {
        if(a.x < b.x) return true;
        else if(a.x == b.x && a.y < b.y) return true;
        else return false;
    }
};

node a[15010];

void init() {
    memset(bintree, 0, sizeof(bintree));
    memset(level, 0, sizeof(level));
}

int lowbit(int n) {
    return n & (-n);
}

void update(int pos, int val, int len) {
    while(pos <= len) bintree[pos] += val, pos += lowbit(pos);
}

int getsum(int pos) {
    int sum = 0;
    while(pos > 0) sum+= bintree[pos], pos -= lowbit(pos);
    return sum;
}

int main() {
    int n;
    scanf("%d", &n);
    rep(i, 0, n) scanf("%d%d", &a[i].x, &a[i].y);
    int tmp;
    tmp = a[0].y, a[0].y = 1;
    repp(i, 1, n) {
        if(a[i].y == tmp) a[i].y = a[i-1].y;
        else tmp = a[i].y, a[i].y = a[i-1].y + 1;
    }
    sort(a, a + n);
    init();
    rep(i, 0, n) {
        int sum = 0;
        sum = getsum(a[i].y);
        level[sum]++;
        update(a[i].y, 1, n);
    }
    rep(i, 0, n) printf("%d\n", level[i]);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值