猴子放箱子吃香蕉题(Problem ID:1069)

题址:http://acm.hdu.edu.cn/showproblem.php?pid=1069

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.


Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.


Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".


Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0


Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


思路:由题意可知,可以先将三个数作为不同的长宽高,将箱子分为不同的状态(长宽高不同),然后再按照cmp函数规则对不同箱子进行排序,按照题意,长越大的越可以作为最底部的箱子,通过调用STL库的sort函数进行排序,用dp[]数组记录箱子的高。

    注意,动态规划第一层是i从k-2开始,即从箱子长*宽第二小的开始扫,第二层j从i+1开始扫,找有没有更小的面能完全放在第一层确定的箱子上面构成最优解。每做一次能求出一个dp[i]。在这有一个重要的点,千万弄懂了,动规dp[i]数组在这里表示当前,取到i编号箱子,的最优解。


AC代码:

#include<iostream>
#include<stdio.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int dp[111];

struct node
{
	int l,w,h;
}box[111];

bool cmp(node a,node b)
{
	if(a.l>b.l)	return true;
	if(a.l==b.l && a.w>b.w)	return true;
	return false;
}

int main()
{
	int d[3],n,i,j,c=1,k,sumh;
	while(scanf("%d",&n)!=EOF && n)
	{
		k=0;
		//printf("此时的k为:%d\n",k);
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&d[0],&d[1],&d[2]);
			sort(d,d+3);
			box[k].l=d[2];box[k].w=d[1];box[k].h=d[0];k++;
			box[k].l=d[2];box[k].w=d[0];box[k].h=d[1];k++;
			box[k].l=d[1];box[k].w=d[0];box[k].h=d[2];k++;
		}
		//printf("此时的k为:%d\n",k);  //k代表有k种形态的箱子
		sort(box,box+k,cmp);
		for(i=0;i<k;i++)
		{
			dp[i]=box[i].h;
			//printf("%d\t",dp[i]);
		}
		//putchar(10);
		for(i=k-2;i>=0;i--)  //第一层先取一个面,下面第二层是表示,找更小的面能不能放上第一层那个面上面
		{
			for(j=i+1;j<k;j++)  //至于放不放上去是由if判断的,但是具体的放没放程序员是无法直接看出来的,但是结果第i个的最优解dp[i]是能知道的
			{
				if(box[i].l>box[j].l && box[i].w>box[j].w)
					if(dp[i]<dp[j]+box[i].h)
						dp[i]=dp[j]+box[i].h;  
			}
		}
		sumh=dp[0];
		for(i=0;i<k;i++)
			if(sumh<dp[i])  //注意:dp[i]表示当前取到i编号这个箱子的最优解,即能叠起来的最高的高度
				sumh=dp[i];
		printf("Case %d: maximum height = %d\n",c++,sumh);
	}

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是一个简单的猴子箱子香蕉的Python代码实现,使用了深度优先搜索算法: ```python # 定义状态类 class State: def __init__(self, monkey_pos, box_pos, banana_pos, direction): self.monkey_pos = monkey_pos self.box_pos = box_pos self.banana_pos = banana_pos self.direction = direction def is_valid(self): # 判断猴子箱子香蕉是否在边界内 return all(0 <= x < 10 for x in self.monkey_pos + self.box_pos + self.banana_pos) def is_goal(self): # 判断是否到达目标状态 return self.box_pos == [9, 9] and self.banana_pos == [9, 8] def get_successors(self): # 找到所有合法的后继状态 successors = [] movements = [(0, 1), (0, -1), (1, 0), (-1, 0)] for m in movements: # 猴子朝向 direction = m # 猴子走一步的位置 monkey_new_pos = [self.monkey_pos[0] + m[0], self.monkey_pos[1] + m[1]] # 箱子移动后的位置 box_new_pos = [self.box_pos[0] + m[0], self.box_pos[1] + m[1]] # 猴子是否可以推箱子 if monkey_new_pos == self.box_pos: box_new_pos = [self.box_pos[0] + m[0], self.box_pos[1] + m[1]] # 箱子移动后是否在边界内 if 0 <= box_new_pos[0] < 10 and 0 <= box_new_pos[1] < 10: # 添加新的状态 successors.append(State(monkey_new_pos, box_new_pos, self.banana_pos, direction)) else: # 添加新的状态 successors.append(State(monkey_new_pos, self.box_pos, self.banana_pos, direction)) return successors # 深度优先搜索 def dfs(state, visited): # 判断是否到达目标状态 if state.is_goal(): return True # 遍历所有合法的后继状态 for successor in state.get_successors(): # 判断状态是否合法 if successor.is_valid() and successor not in visited: # 添加当前状态到已访问列表 visited.add(successor) # 递归搜索 if dfs(successor, visited): return True return False # 初始化状态 initial_state = State([2, 2], [2, 3], [2, 4], (0, 1)) # 记录已访问的状态 visited = set() visited.add(initial_state) # 进行搜索 if dfs(initial_state, visited): print("找到解决方案!") else: print("未找到解决方案!") ``` 这个代码只是一个简单的实现,可能并不完善。如果您有更好的实现方法,欢迎分享!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值