HDU 1069 Monkey and Banana by Assassin

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.


Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

思路:
这个题目是一个简单的dp,数据之小简直难以置信。。。n最大才30.下面讲思路
这是一个造塔的过程,有n中不同的建筑材料,每个材料不限个数,可以翻转,就是一个r*l*h的长方体可以有三种放的方法。造塔的时候严格遵守从下到上下面长宽必须都分别大于上面的长宽
那么我们首先用一个结构体a纪录每个材料三种不同的叠放情况,之后两边递减的顺序sort一发。
用dp[i]表示用到某纪录叠放状时最大可达到的高度递推公式为:
dp[i]=max(dp[j]+a[i].h,dp[i]); (j小于i)

一个两层for循环实现即可,最后全部检索一变取得最大值即可。下面时代码

#include<bits/stdc++.h>
#define input freopen("input.txt","r",stdin)
using namespace std;
typedef struct node
{
    int l,r,h;
}node;
node a[1000];
int value[3];
int cmp(node x,node y)
{
    if(x.r>=y.r)return 1;
    else if(x.r==y.r&&x.l>=y.l)return 1;
    return 0;
}
int dp[1000];
int main()
{
    input;
    int step=1,maxx;
    int n,i,j,tmp;
    while(cin>>n&&n)
    {
        tmp=1;
        a[0].h=0xfffff;a[0].r=0xfffff;a[0].l=0xfffff;  //注意初始化,否则第一个没法赋值的 
        for(i=1;i<=n;i++)
        {
            cin>>value[0]>>value[1]>>value[2];
            sort(value,value+3);
            a[tmp].r=value[0];a[tmp].l=value[1];a[tmp++].h=value[2];
            a[tmp].r=value[0];a[tmp].l=value[2];a[tmp++].h=value[1];
            a[tmp].r=value[1];a[tmp].l=value[2];a[tmp++].h=value[0];
        }
        memset(dp,0,sizeof(dp));
        sort(a+1,a+tmp,cmp);
        for(i=1;i<tmp;i++)
        {
            for(j=0;j<i;j++)
            {
                if((a[j].r>a[i].r&&a[j].l>a[i].l&&dp[j]+a[i].h>=dp[i]))
                {
                    dp[i]=dp[j]+a[i].h;
                }
            }
        }
        printf("Case %d: maximum height = ",step);
        step++;
        for(maxx=0,i=1;i<tmp;i++)
        {
            if(maxx<dp[i])
            {
                maxx=dp[i];
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值