NYOJ-221 Tree(前序中序推后序)

Tree

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB
上传者

苗栋栋


思路:

       已知前序和中序, 推后序;

       总体思路就是找出三种遍历各自的结构(顺序)特点; 

       可以发现,前序遍历的结构是 “根 左 右”, 中序是“左 根 右”, 后序是“左 右 根”.并且在当前节点的左右子树中也是同样的结构;

       因此,在已知前序和中序的情况下,只需要根据前序确定根的值,然后根据中序确定左右子树长度,然后不断递归即可.


代码:

#include <stdio.h>
#include <string.h>

char a[30], b[30];

void f(int l_s, int l_e, int r_s, int r_e);

int main()
{
	while(~scanf("%s%s", a, b)){
		int len = strlen(a) - 1;
		f(0, len, 0, len);
		printf("\n");
	}

	return 0;
}

void f(int l_s, int l_e, int r_s, int r_e)
{
	if(l_e < l_s) return;
	if(l_e == l_s){
		printf("%c", b[r_s]);
		return;
	}
	int i;
	for(i = r_s; ; i++){
		if(b[i] == a[l_s]) break;
	}
	int len = i - r_s;
	f(l_s + 1, l_s + len, r_s, i - 1);
	f(l_s + len + 1, l_e, i + 1, r_e);
	printf("%c", b[i]);
}        


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值