poj3083_Children of the Candy Corn

Children of the Candy Corn
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8508 Accepted: 3729

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.  

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)  

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.  

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').  

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

分析:两个dfs,一个bfs。dfs如果用回溯的话,会超时。。。。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

char map[45][45];
bool visit[45][45];
int dd[4][2] = {{1, 0}, {0, -1}, {-1, 0}, {0, 1}};
int x_st, y_st, f;
int sum1, sum2, sum3;
int n, m;
int cot = 1;

struct Data
{
	int x, y, sum;
};

queue<Data>q;

void dfs(int x, int y, int num)
{
	if (f == 1)
		return ;
	if (map[x][y] == 'E')
	{
		f = 1;
		return ;
	}
	int i = (num + 3) % 4;
	for (int  j = 0; j < 4; j++, i = (i + 1) % 4)
	{
		if (f)
			return ;
		int k = x + dd[i][0];
		int l = y + dd[i][1];
		if (k >= 0 && l >= 0 && k < n && l < m && map[k][l] != '#')
		{
			cot++;
			dfs(k, l, i);
		}
	}
}

void dfs2(int x, int y, int num)
{
	if (f == 1)
		return ;
	if (map[x][y] == 'E')
	{
		f = 1;
		return ;
	}
	int i;
	for (int i = (num + 1) % 4,j = 0; j < 4; j++,i = (i + 3) % 4)
	{
		if (f)
			return ;
		int k = x + dd[i][0];
		int l = y + dd[i][1];
		if (k >= 0 && l >= 0 && k < n && l < m && map[k][l] != '#')
		{
			cot++;
			dfs2(k, l, i);
		}
	}
}


void bfs(int x, int y)
{
	visit[x][y] = 1;
	Data data, c;
	data.x = x;
	data.y = y;
	data.sum = 1;
	q.push(data);
	while (!q.empty())
	{
		data = q.front();
		q.pop();
		for (int i = 0; i < 4; i++)
		{
			c.x = data.x + dd[i][0];
			c.y = data.y + dd[i][1];
			if (c.x >= 0 && c.y >= 0 && c.x < n && c.y < m && !visit[c.x][c.y] && map[c.x][c.y] != '#')
			{
				if (map[c.x][c.y] == 'E')
				{
					f = 1;
					sum3 = data.sum + 1;
                    return ;
				}
				c.sum = data.sum + 1;
				visit[c.x][c.y] = 1;
				q.push(c);
			}
		}
	}
}

int main()
{
	int t;
    scanf("%d", &t);
	while (t--)
	{
		memset(map, 0, sizeof(map));
		memset(visit, 0, sizeof(visit));
        f = 0;
		cot = 1;
		scanf("%d%d", &m, &n);
		getchar();
		for (int i = 0; i < n; i++)
		{
			gets(map[i]);
			for (int j = 0; j < m; j++)
			{
				if (map[i][j] == 'S')
				{
					x_st = i;
					y_st = j;
				}
			}
		}
		int k;
		if (y_st == 0)
			k = 3;
		else if (x_st == 0)
			k = 0;
		else if (x_st == n - 1)
			k = 2;
		else if (y_st == m - 1)
			k = 1;
		dfs(x_st, y_st, k);
		sum1 = cot;
		memset(visit, 0, sizeof(visit));
		f = 0;
		cot = 1;
		dfs2(x_st, y_st, k);
		sum2 = cot;
		memset(visit, 0, sizeof(visit));
		f = 0;
		while (!q.empty())
			q.pop();
		bfs(x_st, y_st);
		printf("%d %d %d\n", sum1, sum2, sum3);
	}
	return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值